2

I've created a SP2010 workflow in SP2013 and I want to edit the collect data / approval task workflow forms. Trying Quick Publish in InfoPath Designer results in the following error:

An unknown error has occurred. The form template has been published to the server but it can only be opened in infopath filler

It's driving me mad.

I've found and tried the following workarounds:

  • Increase execution time in web.config, restart IIS (didn't work)

  • Use the highest privileged user (didn't work)

  • Make sure no other users have the form checked out (didn't work)

  • Re-register the workflow service (didn't work)

  • Increase the ViewStateTreshold (didn't work)

I've also found this thread where somebody is claiming this simply cannot be done, but without official confirmation I find that hard to believe: http://social.technet.microsoft.com/Forums/en-US/sharepointcustomization/thread/42956f82-748f-487e-b9c3-5e0eec5d926d#42956f82-748f-487e-b9c3-5e0eec5d926d

Right now I've set InfoPath logging to Verbose. Here's a small dump of ULS containing the one and only error I could find:

Entering monitored scope (Request (GET:http://sharepdevx01:80/demandmanagement/Workflows/Business%20Request%20Management/Assign%20IT%20Architect.xsn?OpenIn=PreferClient&NoRedirect=true&XsnLocation=/demandmanagement/Workflows/Business%20Request%20Management/Assign%20IT%20Architect.xsn)). Parent No Name=Request (GET:http://sharepdevx01:80/demandmanagement/Workflows/Business%20Request%20Management/Assign%20IT%20Architect.xsn?OpenIn=PreferClient&NoRedirect=true&XsnLocation=/demandmanagement/Workflows/Business%20Request%20Management/Assign%20IT%20Architect.xsn) Non-OAuth request. IsAuthenticated=True, UserIdentityName=0#.w|client-com\sp_admin, ClaimsCount=24 HTTP Request method: GET Overridden HTTP request method: GET HTTP request URL: /demandmanagement/Workflows/Business%20Request%20Management/Assign%20IT%20Architect.xsn?OpenIn=PreferClient&NoRedirect=true&XsnLocation=/demandmanagement/Workflows/Business%20Request%20Management/Assign%20IT%20Architect.xsn Failed to get document content data. System.ComponentModel.Win32Exception (0x80004005): Cannot complete this function at Microsoft.SharePoint.SPSqlClient.GetDocumentContentRow(Int32 rowOrd, Object ospFileStmMgr, SPDocumentBindRequest& dbreq, SPDocumentBindResults& dbres) Could not get DocumentContent row: 0x80004005. Spent 0 ms to bind -1 byte file stream Failure when fetching document. 0x80070012

It's not really clear to me what is causing this.

Can anyone help me figure this out?

  • I am facing the same issue, and this is driving me crazy.<br/> Some one please help. – Purnil Soni Aug 6 '13 at 9:05
  • I am trying to resolve above issue from last 2 days but not able to resolve. <br/> Can anyone help me out in resolving this issue..<br/> Help about this would be really appreciated. – user18739 Aug 6 '13 at 9:11
5

I solved this problem by installing the 'Desktop Experience' Windows feature - go to Server Manager > Manage > Add Roles And Features > Features > User Interfaces and Infrastructure > Desktop Experience. This feature is required to allow SMB-based viewing of SharePoint files (the 'Open in Explorer' option), and it seems InfoPath uses this method of updating files on the server.

I too wasted a day of my life on this, and eventually came up with this solution working through server logs and a procmon of a failure.

Why InfoPath couldn't display a more sensible error is beyond me!

This was on a Server 2012 / SharePoint Server 2013 / SPD 2013 / InfoPath 2013 environment.

  • Thank you! I was completely stumped why I couldn't upload my templates on a new SP2013 workflow. You're a life saver! – Lee Harrison Dec 10 '13 at 19:26
  • TKS From BRAZIL ! It worked for me too! – Luis Filipe Apr 23 '14 at 22:28

protected by Community Apr 13 '16 at 22:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.