I am using SharePoint 2016 on Windows Server 2016 (with GUI). Created a new SharePoint 2010 type workflow and started approval process which automatically created a task form. I then opened that task form in InfoPath 2013 and tried to publish it without making any changes but getting error:

The form template has been published to the server but it can only be opened in infopath filler

I keep seeing that I need to enable Desktop Experience but that is for Windows 2012. I am not sure if I have Desktop Experience on Windows Server 2016 but I am connected via RDP and there is GUI and everything so I guess Desktop Experience is enabled?

How do I fix this issue?

1 Answer 1


You may check your version of Windows Server 2016 via registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\InstallationType 

For OS with Desktop Experience, the REG_SZ Value is "Server" and otherwise the value is "Server Core".

You cannot just enable this feature if you are in another version, a clean installation is required.

Reference: programmatically check if desktop experience is installed or not windows server 2016.

  • Installation type is "Server" Oct 14, 2020 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.