Upgraded my production farm to FEB 2012 CU from OCT 2010 CU a couple weeks ago and things went ok for the most part nothing major issue wise, however I ran a full sync in my User Profile Service weekend before last and started encountering the following report in my logs. I'm not able to identify if there is any impact to any of the user attributes i'm syncing at this time but i wanted to throw this error out incase others have seen the problem and know what i can check.

FIM client is reporting " stopped-extension-dll-exception "

Then i see event ID: 6801, 3 times corresponding to the three times the above FIM client status is reporting.

The extensible extension returned an unsupported error. The stack trace is:

"System.Net.WebException: The remote server returned an error: (404) Not Found. at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request) at System.Net.WebClient.DownloadData(Uri address) at Microsoft.Office.Server.UserProfiles.ManagementAgent.ProfileImportExportExtension.DownloadPictures(ProfileChangeData[] profiles) at Microsoft.Office.Server.UserProfiles.ManagementAgent.ProfileImportExportExtension.Microsoft.MetadirectoryServices.IMAExtensibleFileImport.GenerateImportFile(String fileName, String connectTo, String user, String password, ConfigParameterCollection configParameters, Boolean fFullImport, TypeDescriptionCollection types, String& customData) Forefront Identity Manager 4.0.2450.47"

I had no problems with my imports before the upgrade, we do export the profile images from sharepoint to AD incase this could be related.

  • Following the service pack did you run PSCONFIG or PSConfigUi? Is the User Profile Sync Service still running or did you have to reprovision it? Did you have any changes to your AAMs in the time around the service pack application? Sep 11, 2012 at 11:37
  • Following the service pack i did run PSCONFIG...i ran it on each patch all the way up to FEB 2012, once the PSCONFIG was completed i reprovisioned UPS by using the manage services on server start function...i did not delete and recreate the service application. I am not aware of any changes to my Alternate Access Mappings...when i go into CA i see that they are still there...is there something related to those possibly?
    – Jacob A
    Sep 11, 2012 at 13:44
  • Hi Jacob, did you ever get this resolved? I read somewhere if you want to export photo's back to AD from SharePoint, having mysites enabled is a pre-requisite. Is this the case for you? I'm experiencing the exact same error as you, and if I remove the export to AD for the picture property, the error disappears and FIM is successful. Jan 17, 2013 at 22:00
  • Anthony, i have answered my question and maybe it will help you.
    – Jacob A
    Feb 6, 2013 at 14:39

2 Answers 2


So I found out the problem to this and it was related to the location of the image. My developer had put a timer job in place before i came to work with the company that would take any new users that had not created a profile or image and set them to a default image in the user profile image store...so he used an image that he assigned to one of his test accounts. So the timer job essentially replaced all of the picture values in the user list if value = NULL to the link of the test users image.. but the test users image eventually was deleted and until i ran a full sync after upgrading, the sync service never saw this change with the incrementals and never errored...even though the field for those users was still set to a value that had no image any longer.

SO once the full crawl kicked off after upgrading it noticed that all of those images had no real image associated to the link and would fail the full sync as it could not properly resolve them. I was able to find this out by running a SQL query against the user profile database for those profile values and noticed a large number of users that were pointing to the test users image link.

Once i uploaded an image to the test users account and ran a full sync the problem resolved itself and our syncs are fine now.

I do have to figure a way to go back in and reset all of those accounts safely back to NULL but for now the sync is happy. Cheers!


May not be the exact same issue, but I've found that even though Microsoft says best practices is not to have any account run as local admin the permissions sometimes get hosed during CUs and you either need to set the account to local admin when you first start up the UPS or else set very granular permissions to the 14 hive.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.