0

I am testing an upgrade of a 2016 Server farm to SharePoint Server 2019. I'd originally done a test of one content DB to it's own web app. After ironing out some issues found there, we did a test of all content DBs. Having forgotten about the initial test, of course the copy of that same content DB on a new web app came in with zero sites due to already having those sites existing in the other web app. I detached the original test content DB and deleted the original test web app, but even after detaching/reattaching the content DB on the new web app, it still shows 0 sites.

I have double checked the allwebs table in SQL to confirm that it is the correct database (and not an accidentally created empty DB). I have tried attaching in both the Central Admin site and via Powershell. Tried the RefreshSitesInConfigurationDatabase() command on the new database after removing the old web app. Test-SpContentDatabase does not show any orphan webs.

Anyone have thoughts beyond blowing away the new web app, make a new new web app and reattach all the content DBs (3) to the new new web app? One other note, the other 2 content DBs on that web app are working fine.

0

First of all,make sure the database name and database server is totally right when you mount it.

After running powershell Mount-spcontentdatabase, does the CurrentSiteCount show as 0?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.