I'm trying to import a list from Sharepoint On-Premise to Sharepoint Online. In the old list, the text was wrapped for both the title and the hyperlink column which gave the list an organized and clean look. After the import to Sharepoint Online, the title and hyperlink column are no longer wrapped and it doesn't seem like I'm able to change it in the column settings. I was trying to use the JSON formatting to fix it but I wasn't able to get it to work. Is there any way to do this?

Pictures below to show the difference: Old: enter image description here

New: enter image description here

4 Answers 4


You can force the list to display in the classic view by going to the List settings > Advanced Settings > List experience and selecting Classic experience:

enter image description here

In the modern lists, you can adjust the width of the column and then save the view. The column width will be then stored in the view and other users will be able to see this change.enter image description here

In terms of wrapping the hyperlink field's text, I am afraid there is no out-of-the-box way of doing it.


As we can easily drag the length of the column, automatic line wrapping is canceled by default in SharePoint Online. Agree with Denis, you can use classic experience instead. Also, you can use multiple lines of text column instead of single line of text column and link column(use hyperlink). enter image description here

You can give your feedback to Microsoft if you don't want to recreate columns via UserVoice. It is a place for customers provide feedback about Microsoft SharePoint products. What's more, if a feedback is high voted there by other customers, it will be promising that Microsoft Product Team will take it into consideration when designing the next version in the future.


Just use the Formatter to display Title value

   "$schema": "https://developer.microsoft.com/json-schemas/sp/v2/column-formatting.schema.json",
   "elmType": "div",
   "txtContent": "@currentField"

Note that the options on Title will disappear. Those are the reasons why you don't get the text wrapping in the first place


Although text wrap in hyperlink field multiline text field won't work due current limitation, you can use workaround instead of building a brand new SPFX just for the issue.

How Use other columns (with long text) and use text wrap, or define row height. This way, the multiline column is piggybacked off another non-multiline column. Yet, you can take advantage of its row height adjustment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.