1

I am new to SharePoint. Currently, I am trying to add this app (https://github.com/SharePoint/sp-dev-fx-webparts/tree/master/samples/react-script-editor-onprem) to my SharePoint site. I have followed the instructions given, but it does not show on my page after installing the app.

2
  • Please describe the steps what you have followed. – GSD - SharePoint Apr 17 '20 at 5:19
  • 1
    The following steps is what I have followed: 1. I uploaded and deployed the sppkl file in my appcatalog list 2. Then I added the apps on "App you can add" from my site where I like to use this app. 3. The app already installed and showing on my site content. After these steps, I should able to see the webpart in my home page, but it does not show up. – Gan Apr 17 '20 at 13:39
1

Firstly,after you upload your sppkg file to app catalog,you need to add it to your site. enter image description here

Secondly,after it finishes installing,you could see it in your site contents. enter image description here Thirdly,we need to add the web part to page and add script in it.If you do not host your web part in CDN,you still need to run a command ‘gulp serve --nobrowser’. enter image description here And you could know more about how to deploy SPFX from here: https://docs.microsoft.com/en-us/sharepoint/dev/spfx/web-parts/get-started/build-a-hello-world-web-part

2
  • Ya, I already followed the step you stated. Still not showing... I have already read the link few times from since two day ago. Still not helping. I have ever deplyed this on my sharepoint online developer account once. It require some cmlet which is not availabe on sharepoint on premise. I watched the tutorial from youtube, the guys said the cmlet help to enable the app to modern level. By default it will remain on tenant level, that why it would not show up on home page. It does working. But this morning I check my developer account again, it was disappeared. – Gan Apr 17 '20 at 14:19
  • I'm having a similar issue with a Web Part inside an Add-in for SharePoint Online. I can see the web part when I install the App in a Developer Site, but I can't see the Web Part in the popup to add it to a page of a Team or Communication Site. When trying to add the Web Part to a Team or Communication site, I don't have any problem adding the App to the App Catalog of my Site Contents. In fact, I can even run the Add-in on the site, but I can't find the Web Part. – Shawn Eary Apr 2 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.