1

There is a document titled, we'll say its titled myDocument.pdf located at the following url: http://<rootCollection>/sites/<siteCollection>/<subSite>/<library>/myDocument.pdf. A User, Jim, uploaded the document and sent the link to another User, Mary. Mary couldn't locate the document by clicking the URL. It took her to the default page not found/does not exist page. I get called, and asked to give her permissions to see the document. A few things came to light when I look into the situation:

  1. I can't see the document with my regular account, Site Collection Admin account, or the Farm account.
  2. SharePoint Designer shows the same thing. It's not there.
  3. Powershell also can not find the document.
  4. The search service can't find it.

I go to Jim's desk and tell him the document must not exist, and he pulls it right up. With the same URL, and everything. We check the permissions, URL, etc... The document inherits permissions from the library, and all staff are supposed to be able to see it. I tried giving it its own unique permissions, checking if I can see... Doesn't work. Deleted unique permissions so it inherits again. Still not visible.

We can't find the document anywhere, except with Jim's own user account.

Has anyone come accross this before? How can I solve it?

2

It might be possible that the document has not been checked in. Although you should be able to see the document with SCA or farm admin account.

Navigate to the library -> Library Settings -> Manage File with No checked in version. See if you find the document listed there. If yes, then ask the user to fill out the required properties and checkin the document.

  • Thank you, this actually fixed the issue. It's strange that no other account was able to see the items though... – KGlasier Oct 19 '18 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.