I added a document as site admin to a public folder. If I search for it as an admin, I can find it. But if I try to search for it as a common user, it can't find it. Even if the users can see and open it inside the folder, not appears in the search results. I am using the default view of the folder, so that option is not the reason. The folder is public for anyone so I don't know how the search results are different. The common users have "contribute" permission and I am using SP 2016. Thank you for any advice!

UPDATE: Looks like the contributors can't even find the folders as search result. (They can see or open them manualy.)

1 Answer 1


If the permissions are set properly but it's still not populating in search results, there might be something wrong with indexing. Have you tried reindexing and searching again?

  • Thanks for the advice, but I did that and the result is the same. Also as administrator I CAN find it. Only the contributors have no results at all.
    – Nefri
    Commented Jun 8, 2018 at 14:49
  • Does the issue also apply to docs outside that folder or in other foldere? Commented Jun 10, 2018 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.