0

Created a flow while a file is uploaded to a document library, it is getting failed? But for the item created in a list, the flow is working fine don't know why it is not triggered for file upload.

enter image description here

enter image description here

Any workaround?

  • do you see any errors in log (Run History)? – Akshay Randive Oct 16 '17 at 7:43
  • In run-history it is not even started. [no log present] when I click on Learn more link, I see the trigger failed message. – Vinod kumar G Oct 16 '17 at 7:47
  • can you post the screenshot of steps so that i can try it with my tenant – Akshay Randive Oct 16 '17 at 7:48
  • Added the screenshot, pls check.@AkshayRandive – Vinod kumar G Oct 16 '17 at 7:58
1

the flow is working fine at my end, are you uploading file to correct folder? or just on root of document library?

enter image description here

enter image description here

Update: there are 2 triggers for File upload event.(refer above image)

  1. triggers when you upload file to root document library

  2. will trigger when you upload file to some folder already present in document library.

So if you are uploading file to root you need to change trigger to 1st in above screenshot if you are uploading in some folder in Document library user trigger 2

  • Just at the root of document library, do they make any difference ? – Vinod kumar G Oct 16 '17 at 8:51
  • updated in answer – Akshay Randive Oct 16 '17 at 9:00
  • Did that helped you? – Akshay Randive Oct 16 '17 at 17:02
  • Yes, definitely, i accepted the answer, any idea about moving video files using flow, i am getting error. – Vinod kumar G Oct 17 '17 at 5:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.