I have been working on a Sharepoint migration over the last couple of weeks. Sites have been brought over to our new server (new AD). I got permissions all sorted and we proved that we could do the migration and have all the sites up and working at our end.

I have done a final migration of the content databases from the old server to the new to get the most up to date versions. I used get-spcontentdatabase on the old server, exported the listed databases in .bak format, copied the data over to the new server, stopped the sharepoint services, restored the affected databases from the new backup and restarted all the sharepoint stuff.

I have 4 sites (web applications) in total and 3 of them seem to be up and working.

My problem is that the main site which runs on port 80 is not working since restoring the most up to date database.

I am getting a 404 not found error.

After some googling, I found someone suggestions I add _layouts/sitemanager.aspx to the site URL to see if its just the main page thats not working. I tried this and I get a 500 error.

Is anyone able to help?


I have also tried clearing the cache and restarting the sp timer service as per this post

  • 1
    Did you have a look in the IIS Logs, Event Logs or SharePoint Logs (in CA and ULS logs)? If not you need to investigate that. I not an expert in migration, but I would say that this error is to generic to tell you any solution. Commented Jan 19, 2017 at 11:19
  • As you posted this, I found the issue! The app pool was running as the wrong user. resolved and its up and running! thanks!! :)
    – John
    Commented Jan 19, 2017 at 11:21
  • Maybe add your solution as an answer here and mark it as "Correct Solution", so the next person can have a look at the same spot. And I'm glad I still could help :-) Commented Jan 19, 2017 at 17:38


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.