1

I am building my first SharePoint client-side web part (Hello World part 1). Everything works perfect no issues with the following.

  1. Successfully set up Machine with NodeJs, Gulp, Yeoman etc
  2. Got the Dev Tenant and other setup on it
  3. Got all the scaffolding for first web part using yo command
  4. Ran Gulp Serve command, I can see, add, and play with the helloworld web part on the local:4321 workbench

Now(problem starts here) as per the instructions I open the Workbench page which is hosted on the SharePoint. After accepting the load unsafe script the page opens up. But when I click on that Plus sign there is no hello world web part in the list to add.

Am I missing any step? Video and instruction which I followed does nothing special to get this web part in the list.

enter image description here

  • I tried but the issue not resolved for me. can you explain in detail..? – user84797 Jun 13 at 5:00
2

After scratching my head for some time, I realized that the Gulp task was cancelled. So I did the following

  1. Re ran the Gulp serve command. Which opened the browser with local:4321 workbench.
  2. Without cancelling the Gulp Task, I re open the SharePoint hosted workbench.

Eureka!!!

The problem got solved, and I was able to see the hello world web part in the list.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.