0

I have a sharepoint online developer tenant. I created a document Library called Javascripts. I open the Library in explotrer view to edit the files.

When I edit a file with Visual Studio 2015, I cannot save it. I get an error saying the file is checked out or loked for editing by another user. The library does not even have checkout enabled!)

I can open and edit the files using VS CODE with no problems.

I ran a fiddler trace while trying to save the file from within Visual studio. I see VS sends a Lock Request, and sharepoint responds with an HTTP 423 response: enter image description here

I am on my home computer, not domain joined. I am running windows 10. How can I edit my files using visual studio 2015?

0

It is a filesystem issue, unselect the file in Explorer View, that's what blocking any 3rd party application from editting it.
Explorer has locked the file for its own Explorer purposes.

Best is set a Drive mapping to you SharePoint folder and use that in VS and close Windows Explorer.

http://www.viewmaster365.com/365coach/#/Map_Document_Libraries_as_Network_Shares

0

I am also experiencing the same issue. I tried both avoiding Explorer View and attempting with a mapped drive as Danny '365CSI' Engelman suggested, neither had any impact upon the problem.

One solution I have found is that the problem does not present itself if you edit the files from Visual Studio 2012 instead of Visual Studio 2015.

I wish I had a way to get this working in VS2015 though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.