I posted something similar on stackoverflow yesterday, but didn’t notice there was a SharePoint site in stack exchange until today. So apologies if you have already read this.

I am following the Microsoft tutorial for creating my first SharePoint 2013 app. ( http://msdn.microsoft.com/en-us/library/fp142379.aspx)

On a windows 2008 R2 Server I have installed Sharepoint server 2013 RTM, and done all the farm config stuff, and then installed all of Visual Studio 2012 Ultimate and update 1 and restarted the server. I have also installed Microsoft SharePoint Developer Tools for Visual Studio 2012 and other associated prerequisites.

I have also followed the instructions for "How to: Set up an on-premises development environment for apps for SharePoint" which is at http://msdn.microsoft.com/en-us/library/fp179923.aspx and done the app isolation stuff.

I have got to the point where I’m starting my first project, so I’m running Visual Studio as an Administrator, I have named it and chosen "SharePoint-hosted" and validated the server and clicked finish (Step 5).

Instead of getting the next step where I open the AppManifest.xml file I get a message saying :-

An error occurred whilst trying to load some required components, 
Please ensure the following prerequisite components are installed. 
Microsoft Web Developer Tools
Microsoft Exchange Web Services

I have checked VS setup and web developer tools and SharePoint developer tools are definitely installed. the About in Visual Studio shows

Microsoft Visual Studio Ultimate 2012 v11.0.51106.01 Update 1
Microsoft .NET Framework v4.5.50709
SQL Server Data Tools v11.1.20627.00
Web Developer Tools  v1.0.30710.0
(*These all have 04940-004-0038003-02173 by them*)
Architecture and Modeling Tools 
LightSwitch for Visual Studio 2012 
Microsoft SharePoint Developer Tools for Visual Studio 2012 - Preview - ENU 
Microsoft Visual Studio Tools for Applications  
2012 Office Developer Tools
Team Explorer for Visual Studio 2012
Visual Basic 2012
Visual C# 2012 
Visual C++ 2012 
Visual F# 2012 
Visual Studio 2012 Code Analysis Spell Checker 
PreEmptive Analytics Visualizer v1.0

I have also tried doing other SharePoint projects (like “SharePoint 2013 – Empty project”) and they all gave me the same error message as above.

Also If I download a project (like the “hello world” samples from Microsoft and open them the part of the app that is for SharePoint fails to load with that same message, the web part loads.

Any help would be greatly appreciated. This morning I reinstalled Visual studio and all components just in case but to no avail.

2 Answers 2


Got it after a few trial and errors

With an offline install you have to download the Exchange Web Services component. I had downloaded "EwsManageApi" and installed that.

As the error message specifically refers to Exchange Web services, I looked at other versions and tried the older 1.1 and the 32 bit version, but they didn't work either, ** until ** I relised in my haste that I installed using the default settings (which is for the current user) and not for all users of the machine.

So installing EwsManagedApi32 for all users on a 64 bit server does the trick.


I have found one solution to this issue. Install Microsoft Exchange Web Services Managed API 2.1 (the latest version I can find at this time)

Later i opened visual studio and created new project at this time it is working as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.