4

Im trying to deploy a wsp on a Sp2013-farm. Ive tried restarting all sptimer-services on all machines, restarted admin service on all machines, restarted all machines, recycled service (iis) app pool, retracted wsp from gui, tried deploying it from gui(CA)

Whats left?

  • Have you ran stsadm -o execadmsvcjobs on all members of the farm? – Robert Lindgren Apr 15 '16 at 6:25
  • Yes (now), didnt have any effect – Cowborg Apr 15 '16 at 7:11
1

It turned out that one of the servers stopped the timer service + World Wide Web publishing service due to patches incompatibility and it was waiting on this server to complete. If you have more than one server in your farm ensure that the SharePoint TIMER services are running on all.

How you can check the above:

  1. On any server->start->run->services.msc->enter->this will open the services console.

  2. Now type s-> this will give you all the services that start with S->look for SharePoint timer service and make sure it’s in started mode.

  3. This service should be started on all the front ends as well as application server.

Possible Resolutions

  1. Make sure SharePoint timer service should be started on all the servers (web front ends as well as app server)

  2. Try restarting the SharePoint Administration service on all the servers.

  3. Restart all the SharePoint servers

  4. Make sure that all the servers in farm are on the same time zone.

  5. Execute stsadm -o execadmsvcjobs on all the servers of the farm

  6. Cancel the deployment job by means of central administration, remove the solution and try to add the solution again & check the results.

  7. Check the status of the jobs by means of CA-timer job status or use the following command - stsadm -o enumdeployments This will give you the list of all the pending & active deployments.

After trying all the steps and nothing works then please checks the logs and find out the root cause.

In case of any problems with respect to logs then please share here so that we can help you out!

Hope the above information will be helpful to deploy the solution successfully. Thank you.

Source: http://social.technet.microsoft.com/wiki/contents/articles/21350.sharepoint-2010-troubleshooting-solution-deployment-stuck-on-deploying.aspx

  • When copy-pasting large sections of text (well, when copy-pasting in general) you need to make sure to quote the source of the text! – Robert Lindgren Apr 15 '16 at 6:50
  • 1
    Sure Robert.. I am learning many things from you. I just want to help others. Nothing else is important for me..:) – Hardik Apr 15 '16 at 6:53
  • I'm glad you want to help people out. That is a good trait to have :) – Robert Lindgren Apr 15 '16 at 6:57
  • Thanks man. If you can initiate chat than i have one question that i need to be resolved by anyhow. If we can chat than it will be really helpful for me. – Hardik Apr 15 '16 at 7:00
  • Thanks for your help, i did those step. Dont see anything special in the logs – Cowborg Apr 15 '16 at 7:17
1

I know that it is a very late reply, but, I was stuck in this issue as well and nothing worked out for me. Solution was successfully getting retracted and deployed in two of the WFEs while it was getting stuck for just one WFE server. Finally, we found that equal (=) sign was missing in one of the appSettings entry available in OWSTIMER.EXE.CONFIG file. Conclusion - Hence, If it doesn't work out even after executing all the steps mentioned by Hardik, it is better to take a look at the OWSTIMER.EXE.CONFIG file to see if we have any improperly formatted (that doesn't conform to the config xml standards) entry there.

  • Yes, a bit late, I have changed jobs 2 times since then :D... and Im staying away from SharePoint for the rest of my career so I cant verify it. But Im goiing to give you a +1 for the effort – Cowborg Nov 18 at 10:02
1

this was the problem for us http://www.matt-thornton.net/tech/sharepoint/sharepoint-solutions-stuck-retracting-deploying

$farm = Get-SPFarm
$disabledTimers = $farm.TimerService.Instances | where {$_.Status -ne "Online"}
if ($disabledTimers -ne $null)
{
foreach ($timer in $disabledTimers)
{
Write-Host "Timer service instance on server " $timer.Server.Name " is not Online. Current status:" $timer.Status
Write-Host "Attempting to set the status of the service instance to online"
$timer.Status = [Microsoft.SharePoint.Administration.SPObjectStatus]::Online
$timer.Update()
}
}
else
{
Write-Host "All Timer Service Instances in the farm are online! No problems found"
}
0

One more late replay, but maybe it will be useful for somebody.

Same situation, but in SP2010 farm - have been stuck in both deployment and retracting by the same problem. It was in one of the servers - could not start SharePoint Admin service, because it could not connect to internet... strange and could not explain, but configuring proxy and getting that access allowed to start the service and deployment/retracting went full speed.

0

One more late replay.

Following below worked for me:

  • Restart server
  • Remove wsp from SP farm
  • Stop SPTimer
  • Clear SP Cache
  • Start SPTimer
  • Add and install wsp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.