3

I have an odd problem with a farm where solutions are marked as "Not deployed" yet looking at the last operation it shows "Deployed Successfully" and lists all the servers as being successfully deployed to.

My problem is that without having an accurrate picture of whats deployed I cannot be certain that my changes in the solutions are deployed.

I've tried through both powershell and central admin - no errors are raised in either case.

This question: Solution deploying 'succesfully', yet doesn't.. is similar and I'll try that but I am working in SP2013 not MOSS2007.

3

SharePoint's solution deployment is a bit of a black box. I would try two things:

1) Use -Force on the Install-SPSolution cmdlet to instruct SharePoint to override files, etc., and hopefully result in "Deployed".

2) If #1 doesn't work, I would retract and remove the solution. Then restart the SPAdminV4 and SPTimerV4 Windows Services. Then re-add the solution and use Install-SPSolution with the -Force parameter.

| improve this answer | |
  • Thanks, I tried all of these but unfortunately it was nothing to do with the services but rather a server misbehaving. Taking it out of the farm allowed solutions to deploy correctly. – Mauro Nov 6 '13 at 9:21
1

I encountered the exact same problem on SP2016.

The cause is, one day ago, the service account running Timer service is expired and being reset. After that everything looks run smooth but actually not. Some connection session is still running within the farm. It cause the false message "Deployed Successfully".

The solution is reboot all the servers in the farm to make sure a correct connection is running.

P.S. Beside using "Install-SPSolution" cmdlet, you can also try "Update-SPSolution" which it may trigger different result or shows the real error in some case.

P.S.2 In some cases, the problem is caused by the timer service configuration cache are not in sync between the servers. Clear the caches in all server and reset Timer service could solve it.

| improve this answer | |
0

While Johns answer had some good information and extra steps to try - i finally discovered a server was not functioning correctly after it had been replaced/rejoined to the domain - never removed/rejoined from the farm though.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.