0

Hi I am using SP2013 stand-alone version. I am trying to deploy a solution in SharePoint 2013, I have successfully added the solution to solution store, but whenever I try to deploy the solution, timer job gets created but the timer job do not deploy the solution i.e. if i refresh the central admin page once it show deploying the solution, but after few mins when i refresh the page, it shows 'not deployed', and i also checked logs for any error but could not find any related to this, I tried PowerShell, STSADM & Central Admin, all with same result (yes i tried force also)

Some extra information -

  • My solution needs GACDeployment, CASPolicies if that matters
  • And my SharePoint Time Zone is different from my computer(which i have not fixed yet), I initially thought error is for this, but I tested with some other timer job to find it is not a problem

Any suggestion? thanks in advance

0

I found the solution to the problem, for some reason (I am yet to understand the reason)

stsadm -o deploysolution -name solutionname -url siteurl -allowGacDeployment -allowCasPolicies -immediate 

is not working, in place of -immediate when i used -local (i am using a standalone version so -local does the work for me) i.e.

stsadm -o deploysolution -name solutionname -url siteurl -allowGacDeployment -allowCasPolicies -local

worked like a charm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.