I've created 1500 mysites (pre-provisioning), but there are 25 user that don't get their mysites.

All users can be found after running a sync, but when I try to check for a user with powershell I get:

Exception calling "EnsureUser" with "1" argument(s): "The specified user i:0#.w|awesome\superawesome could not be found."

$site = get-spsite https://awesome.no
$web = $site.OpenWeb()
$user = $web.EnsureUser(“i:0#.w|awesome\superawesome”)

I've tried to find the users using people picker and it works in central admin and in the web application.

I've also tried to check permission on the root page, and I also found the specific user

2 Answers 2


I reconfigured the peoplepicker and it worked like a charm.


It seems this workaround worked for me:

$loginName = "awesome\service_running_sync"

$password = "password123"

$domain = "awesome.no"

$wa = Get-SPWebApplication https://awesome.no

$adSearchObj = New-Object Microsoft.SharePoint.Administration.SPPeoplePickerSearchActiveDirectoryDomain

$userPassword = ConvertTo-SecureString $password -AsPlainText -Force

$adSearchObj.DomainName = $domain

$adSearchObj.IsForest = $false #$true for Forest, $false for Domain 

$adSearchObj.LoginName = $loginName

$adSearchObj.SetPassword( $userPassword )


$adSearchObj = New-Object 

$adSearchObj.DomainName = "local.domain.sync"



A possible root cause could be to be this:

When you execute a People Picker query, that makes a NetBIOS call to try to resolve the domain name. Because the WINS is not set up, a NetBIOS broadcast occurs. However, the broadcast cannot find the trusted domains because broadcasts are not enabled outside the subnet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.