0

I have installed SP 2013 SP1 on my development server which has Windows Server 2012 R2 OS.

I have configured SP 2013 with Configuration Wizard.

After installing, Central Admin was created successfully.

Now I started to creata a site collection, and after I navigate to the url of the newly created site collection, am getting the dreaded

Sorry something went wrong. In the ULS log viewer, am able to see the below error description:

Unexpected  Failed to create instance of cookie value handler 
 type 'Microsoft.SharePoint.IdentityModel.SPSessionSecurityTokenCookieValue'.

Whenever I create a sub site or app (document library, list etc) or navigating to the Site pages library, I am getting the same SecurityTokenCookieValue error.

I have received the below description from event viewer :

Reason: Exception has been thrown by the target of an invocation. Technical Support Details: 'System.Reflection.TargetInvocationException': Exception has been thrown by the target of an invocation. ---> 'System.InvalidOperationException': This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms. at 'System.Security.Cryptography.SHA256Managed..ctor()' --- End of inner exception stack trace --- at 'Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()' at 'Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)'

enter image description here

enter image description here Is there any workaround for this?

  • 1
    couple of things you can do it...#1) try to remove and recreate the Distributed Cache. #2) restart the STS token services app pool. at the end check the event log – Waqas Sarwar MVP Dec 1 '15 at 14:06
  • 1
    check the event log on the server and see if you get any other clue? – Waqas Sarwar MVP Dec 1 '15 at 14:23
  • 1
    also try this Add the following line into the aspnet.config on both FE machine. <enforceFIPSPolicy enabled="false"/> – Waqas Sarwar MVP Dec 1 '15 at 14:24
  • 1
    also check this one blogbaris.blogspot.com/2013/09/… – Waqas Sarwar MVP Dec 1 '15 at 14:44
  • 1
    Let me add this as answer and then you can mark it... – Waqas Sarwar MVP Dec 1 '15 at 15:13
1

Couple of things in this Scenrio, you can try to fix it.

  1. repair the Distributed Cache on the server
  2. Recycle the Security token service and app pool
  3. Or, Add the following line into the aspnet.config on WebFrontend.<enforceFIPSPolicy enabled="false"/>
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.