I have an InfoPath form that has full-trust with a cert. It has 3 data connections for SharePoint lists that are used to populate combo boxes.

Prior to SP1, these worked great. However, post SP1, I'm greeted with the following errors:

List item

  • In the browser, I'm told that I don't have permissions to access the list required for the form.
  • In the ULS logs, I get an error that the list cannot be found.


Cross-domain access is allowed in InfoPath forms Services configuration, even though there are no cross-domain calls happening here.

I have removed all the connections and added them numerous times but still get the errors. Permissions on the list appear to be the same as they were pre-SP1.

I've been able to get the form to work by converting the connections to connection files however, I'm struggling to understand what is causing this error.

On a side-note, I have been able to create a new form using data connections to the same list and it works so it must be something specific to this form. I have looked through all the xml files in the .XSN (CAB) and haven't found any references to invalid list names. Also, the design checker does not find anything wrong with the form.

Based on the configuration of this form, why would the connection files work when the in-form data connections fail?

1 Answer 1


A couple of things to check:

  • Can you access the lists from the browser?
  • Try and open Fiddler on your client machine where you run infopath to see where the requests to the SharePoint lists go
  • check publishurl in manifest (cab) to see that you havent by accident re-published some older version from a test server (happend to me more than i care to admit;-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.