0

I ran to an uncommon situation a few days back. All my intranet SharePoint site users are their permissions set to "Read" More critically worrisome, all my site collection administrators accounts are in full read permissions as well. Using my favorite search engine, I have put a script together which will allow me to explicitly set owners and secondary owners to all my SharePoint Web site, as shown below:

$owner = Read-Host "Enter site collection owner username: "
$second = Read-Host "Enter site collection secondary owner username: "
$sites = Get-SPSite -Limit all
foreach ($site in $sites)
{
    Write-Host Setting $site.url owner to $owner and secondary owner to $second
    stsadm -o siteowner -url $site.url -ownerlogin $owner -secondarylogin $second
}
Write-Host "Done"
$site.dispose()

This little script worked fine for all web site except for the more important one. The "failedspsite" throws an error :

"actions on this web site has been blocked - Contact administrator to resolve the problem".

I have no logs whatsoever, to help me figure out where the problem lies, nor any events logged when the errors is thrown. So all administrator accounts cannot not edit user and group permissions in the "failedspsite" web applications. However, when checking administrator rights in Central Administration GUI I can see that the permissions level are "Full Control" . Below is the screenshot of Site actions menu for my site collections administrator. It's in french but you can clearly see that the permissions

enter image description here

My administration center and WFE server are running on the same box while the SQL server is on another server. It's a SharePoint 2010 SP1 environment with only one server in the farm.

Hope to hear back from you guys very soon, as this issue is blocking my production environment as users are not able to upload, edit, work with documents at all. Only view are permitted.

0

It sounds like your site collection has been locked. In Central Administration, go to Application Management and then click on Configure quotas and locks. Use the drop down menu to find your site collection and see if it is in Read-only (blocks additions, updates, and deletions) mode. If so, set it to Not Locked and click OK.

  • Hello Eric Alexander, I'd like to say thanks for the quick feedback. I spent countless hours on this and knowing it was just that was a relief. Your solution was EXACLTY the answer to my problem. So again thanks. Thanks to people like you this space is rocket helpful. – Asan Soileti Oct 4 '15 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.