2

I'm having an issue where on most of our existing site collections the users specified in the "Site collection administrators" setting under "Site Settings" > "Users and Permissions" do not have the ability to see any of the 'Site Collection Administration" stuff under Site Settings in 2013.

The only way to get the Site Collection Administration stuff to show in site settings for a user is to add them as either the primary or secondary site collection administrator via PowerShell or central admin. This isn't very helpful because we will most likely have more than 2 site collection administrators in a lot of cases.

I mentioned this happens on existing site collections, and that is because if I create a new site collection, then add site collection administrators via site settings, those users do receive all correct permissions and are able to see the site collection administration section in site settings.

Therefore, this looks to be a per-site collection setting of some sort, but I have no idea what may be causing this to occur. Does anyone know how this could have happened and how to change it back to default?

  • This is not standard behavior. Have any farm solutions been added? – Jammin4CO Dec 15 '17 at 20:41
  • Hi @Jammin4CO , the OP asks why the Site Collection Administrators link is only available to Site Collection Administrators, and he need to be available to other users to see the Site Collection Administration stuff , please correct to me if I'm wrong :) – Mohamed El-Qassas MVP Dec 15 '17 at 20:46
  • @M.Qassas My understanding was that the "Site Administration" section of the top-level Site Settings was missing for all Site Collection Administrators except the two specified in Central Administration. If I misunderstood the question, your answer is correct. Otherwise, my clarification question above is necessary. – Jammin4CO Dec 15 '17 at 20:54
  • @Jammin4CO Thank you for your feedback, I totally agree with you, the question requires more clarification. now I am also confused :) so let's wait for the OP clarification! otherwise, we should flag the question as unclear :( – Mohamed El-Qassas MVP Dec 15 '17 at 21:03
  • Correct, i agree this is not standard behavior, but i can't figure out what is different between these existing site collection exhibiting this behavior and new site collections i create which do work correctly. So, this is not a farm wide issue, it is only on pre-existing site collections that this is happening – Adam Barylak Dec 20 '17 at 18:59
1

It's normal behavior in SharePoint,

Only the Site Collection Administrators can see the Site Collection Administrators Link below User and Permission in the Site Collection Settings.

enter image description here

Even the Site Owner can't see the Site Collection Administrators Link!

Check also Site Owner vs Site Collection Administrator

If the Site Collection Administrators Link is available to anyone else who ( not added as Primary or Secondary Site Collection Administrators), this will allow the Site Collection Administrators to be managed by users with less authority and that makes no sense.

So to be able to see the Site Collection Administration stuff and make this link available, you must be A Site Collection Administrator.

Note: The Site Collection Administrators link is only available in the site settings page of the site collection. It's not available in the site setting of the subsite,

Even you are a Site Collection Administrator, you will not find it below User Permission in the site setting of the subsite.

  • You don't understand my issue. When i add a user as a "Site Collection Administrator" via the Site Settings area, they do NOT get the same site collection administrator options as one of the 2 users added via central admin. However, if i create a brand new site collection, then all users added via central admin as well as added via site settings do get the same correct site collection administrator permissions. I'm wondering what is different on the site collections that this doesn't work correctly. – Adam Barylak Dec 20 '17 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.