0

I am receiving a SharePoint Connection Error when connecting to Visual Studio 2012 Sandbox or Farm Solution when I create a new project.

Here is the Error.

enter image description here

SharePoint 2013 on Premise, Alternate access mappings are enabled. There are 3 servers WFE, APP, SQL. I have VS on the APP local. DNS records are on the Active Directory Server.

  • do you reach the sharepoint site with http:// localhost ? – domsen123 May 27 '15 at 14:08
  • I reach the site with http:// intranet externally, but I am on the APP server with Visual studio. http:// intranet throws errors – christopher clark May 27 '15 at 15:00
  • go to your servers host file and write: 127.0.0.1 intranet... be sure you connect visual studio with http:// intranet then – domsen123 May 28 '15 at 10:16
0

If you do a Service pack update, you might face this error when creating a project that connects to the SharePoint site.

Verify that your Login is in the db_owner group on the SQL Instance and also remember that by default (SQL 2012+) the BUILTIN\Administrators group no longer has auto sysadmin rights on new install. So if you are relying on that local security group for rights, it would be best to create a AD Group to manage SQL Instances and leave, or disable, BUILTIN\Administrators group as public only.

Follow this guide step by step and verify each step is true: Account Permissions and Security Settings in SharePoint 2013. This one is more detailed and maybe a little overboard for what you need, but it is the long path for access rights. Refer to #2 for a simpler path.

Another good simple guide: Prepare your SharePoint 2013 farm for App development and debugging. This Guide fixed most of my local development needs.

Also take a look at this link as this is the same error message but in a different form.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.