0

I'd been granted full control of a department site created by someone else and had been attempting to clean up permissions by removing unnecessary or repetitive user groups. I'd created separate user groups for an ownership group (consisting of myself and a couple others with full control) and a group with read rights (so, default users, everyone else within the company); I then removed everyone else since the other groups were unnecessary. This did include both the Records Center Web Service Submitters group and System Account (SHAREPOINT\system) user, since I was not under the impression removing either would affect subsequent access for anyone else, and certainly not myself.

Immediately after doing so, I tried accessing the home page for this site (both via direct link, and the "long way" through my department's site, and received the error message stating I do not have access to this site. Confused, I still had the direct link handy for the permissions page...and was able to bring that up successfully and edit permissions as normal (including adding back all the redundant user groups I'd previously removed, or adding myself outside of a group with full control). From the Permissions page, I can also directly access other parts of the site (not just the All Site Content page, but other things within the site, like lists, libraries, etc.). Despite all that, I am still blocked from accessing the home page. For some reason, I cannot access a "Templates" link from the Quick Launch, but can access it from All Site Content.

Did I do something wrong when I removed all those other user groups, specifically the Records Center group and System Account user, or would that have nothing to do with it? Is there something else I'm not thinking of?

  • Are you a site collection administrator? It is different than being member of the owners group – Arsalan Shahid May 15 '15 at 1:09
  • No, I am not the SharePoint admin/super user for my company. This is a site created by someone else that I have been assigned Full Control rights to, so I could assist in managing it after that person retired. – Adam May 15 '15 at 16:05
  • Site collection administrators are assigned on a per site collection level and have unrestricted access to the whole site collection, despite whatever permissions are applied to any object. Farm Admins, Site Collection Admins and Owners are three different level of security levels. Site Owners do undergo the permissions checking process and can face access denied errors. – Arsalan Shahid May 15 '15 at 16:20
  • My point being, if your permissions are based on being the members of the Owners group, then there is some object in the page on which you don't have permissions to, like a view of a list embedded in the view. If something like this happens, SharePoint will deny access to the whole page. I think this is what is happening in your case. – Arsalan Shahid May 15 '15 at 16:20
  • Check if you are a site collection admin. If not, see if you can get added to the group and if you can then access the page. Another thing that you could try is to append the parameter contents=1 to the home page url e.g. yourserver/Pages/HomePage.aspx?contents=1. – Arsalan Shahid May 15 '15 at 16:23
0

Be sure you didn't remove the Style Resource Readers group. This group provides necessary access to the Master Page library and Style Library.

To check, go to the site in question Site Actions > Site Settings (or http://yoursite/_layouts/settings.aspx) > Master pages and page layouts > Library tab > Click on Permissions > Check Permissions.

Next, check whether or not the Mast Pages Gallery has unique or inherited permissions, or do a Check Permissions on your account.

All users should have at minimum Read rights to this folder as well as the Style Library (under Site Content).

  • I added the Style Resources Readers group back at the site-wide level, but that still has not corrected the issue; I'm still blocked from accessing the front page, but can still continue to access the site's permissions, settings & other pages via direct link. – Adam May 15 '15 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.