0

I have an external user accessing my SharePoint Online site and for some reason when they try to log in they get this message:

Access Denied someemail@email.com does not have permissions to access this resource. Here are a few ideas:

Please ask the site admin to give you access.

If you have a different account, try signing in with that account. This will sign you out of all other Office 365 services that you're signed into at this time. If this problem persists, contact your support team and include these technical details: Correlation ID: # Date and Time: 4/20/2015 1:00:39 PM User: someemail@email.com Issue Type: User does not have permissions.

They were trying to access the SharePoint Online site by logging into the Microsoft Live log in page, so I'm not sure if that maybe the trouble.

3

Access denied is an authorization failure from SharePoint...this might sound crazy, but you didn't specifically mention it in your post, so...did you give them access to the site first? From the error message, it doesn't sound like it.

  • Agreed, can you verify that the site permissions has the particular user - and access levels are sufficient? – Quinn Johns Apr 21 '15 at 2:57
0

Asusming you need yo give permision to anonymous users. to Enable anonymous access on a site

To perform this procedure, an administrator must have enabled anonymous access for the Web application. If they haven't done so, the Anonymous Access option does not appear.

  • Open the site on which you want to enable anonymous access.
  • On the Site Actions menu Button image, click Site Settings.
  • NOTE On a site for which the Site Actions menu is customized, point to Site Settings, and then click the settings that you want to view.
  • On the Site Settings page, in the Users and Permissions column, click Advanced permissions.
  • On the Permissions page, on the Settings menu, click Anonymous Access.
  • On the Change Anonymous Access Settings page, select the parts of your Web site that you want anonymous users to access.

https://support.office.com/en-au/article/Enable-anonymous-access-3647cdd5-1ab8-48cf-b4ee-d1b652bbabdd

  • if external user access is disabled, they cant be added to the site itself. – Swayam Siddha Apr 21 '15 at 6:41
0

I am assuming you are sharing the site via 'share' button on the top right corner.

  1. Are you able to share a site with a user.
  2. Does he/she go through the invitation process, once you share the site with him/her
  3. Are you adding the user to the right group ?

This is a good starting point

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.