1

I have a SP 2013 workflow feature that needs activation, when I perform the stsadm command and get the below mentioned error:

Microsoft.Workflow.Client.ActivityValidationException: Workflow XAML failed validation due to the following errors:
Cannot set unknown member 'LookupSPListItem.ItemId'. HTTP headers received from the server - ActivityId: 056f7427-f724-4
628-b61a-cdef4e3bc731. NodeId: S-SHP-SHK-01. Scope: /SharePoint/default/7eabb605-2300-4b23-b758-fbd88b3ab02c/e8e06602-c4
71-4fe8-b076-79d86bbca942. Client ActivityId : f464fa9c-5ed3-3022-9eb2-3b00a6271e36. ---> System.Net.WebException: The r
emote server returned an error: (400) Bad Request.
   at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)
   at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.End(IAsyncResult result)
   at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)
   --- End of inner exception stack trace ---
   at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)
   at Microsoft.Workflow.Client.WorkflowManagementClient.SendRequest[T](HttpWebRequest request, T content)
   at Microsoft.Workflow.Client.ActivityManager.Publish(ActivityDescription description, Boolean overwriteXClassName, Bo
olean terminateDependentInstances)
   at Microsoft.SharePoint.WorkflowServices.FabricWorkflowManagementClient.PublishActivity(String serviceGroupName, Acti
vityDescription activity, Boolean overwriteXClass, Nullable`1 terminateInstances)
   at Microsoft.SharePoint.WorkflowServices.FabricWorkflowDeploymentProvider.PublishActivity(FabricWorkflowManagementCli
ent client, ActivityDescription activityDefinition, String serviceGroupName)
   at Microsoft.SharePoint.WorkflowServices.FabricWorkflowDeploymentProvider.<>c__DisplayClass5.<PublishDefinition>b__4(
)
   at Microsoft.SharePoint.WorkflowServices.WorkflowServiceContextExtensions.InvokeWithEcosystemRetry(WorkflowServicesCo
ntext context, EcosystemRequiredMethod method)
   at Microsoft.SharePoint.WorkflowServices.FabricWorkflowDeploymentProvider.PublishDefinition(WorkflowDefinition workfl
owDefinition)
   at Microsoft.SharePoint.WorkflowServices.WorkflowDefinitionStorageEventReceiver.PublishDefinition(SPItemEventProperti
es properties)

Am I missing any Dlls?? The SharePoint version is 15.0.4569.1000.

1

I did find a solution.. However I don't know how practical it is. This is what I did:

  1. Installed Visual Studio 2012 on my Staging. Updated it with 'Update 4'.
  2. Installed office tool for VS 2012.
  3. Got the work flow code and deployed it via Visual Studio. (And the deployment worked).
  4. Retracted the solution via Visual Studio.
  5. Added the .wsp files manually via STSADM command and activated the features successfully.

Since it was the staging environment, I had the liberty of rebooting the server many times.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.