8

I have a need to add a hyperlink in a wikipage to open a file in a shared drive. Uploading the file to SharePoint is not an option in this case (due to record compliance, intranet in SP now - document management in SP with a proper taxonomy and R&D later).

Couple of things:

  • I am using IE 9
  • SharePoint Online
  • Have added intranet.sharepoint.com (the site in question) to my trusted sites

I have tried the following formats with no success (i.e. nothing happens when I click on the link, not even an error message):

file://X:/Some/Folder/Docname.docx and file:\\X:\Some\Folder\Docname.docx

Copying the link and pasting it into another browser opens the document but the same link on the SP wiki page (have tried 'open in new tab' and 'open in new window' by right clicking and by setting the link to do so and nothing happens (no error message, nothing at all).

What are the other internet settings I am able to amend to allow this, should I try all the above again using the full path with server name included (I think I tried this earlier and no luck) or is there an additional solution?

Thanks in advance

  • I can confirm that it works - but only in IE Chrome does not follow the link, but understands the "URL" when pasted directly into the address bar – Lars G Olsen Mar 12 '17 at 18:42
4

I realize this is very late. The above did not work for me so this was my work around:

  1. Create a shortcut to the network file
  2. Upload the shortcut to a document library in the site it is being linked to
  3. Use a link to the shortcut to the network file, in the SharePoint library, for your network file link

I used this in Navigation and it works perfect.

| improve this answer | |
3

I've also had trouble linking to shared drives in older SharePoint versions. It tends to flip all of my backslashes (\) to forward slashes (/), thus turning the file path into a URL. Sometimes this occurred while editing, sometimes after saving. To determine if this is the issue, hover over the link after saving or publishing to confirm all of your slashes are properly faced. I'm not seeing this issue in SharePoint 2013.

| improve this answer | |
2

The format \\server\%path%\%file_name% should work on a SharePoint wiki page.

Make sure you're copying the actual path from the network drive, rather than it's relative path as a mapped drive.

| improve this answer | |
  • Thanks, unfortunately still no luck. My SP 365 site is not mapped to my network (is this why?) this full path will open in a browser window if I copy the hyperlink into a new window though – user40424 Mar 11 '15 at 20:15
  • And make sure you are using IE. It won't work in Firefox, Chrome, Edge, etc. – TylerH Sep 1 at 19:09
0

This is what we discovered:

When you are posting a link to the file, make sure to make all slashes forward (/), spaces in %20 format, etc. So pretty much convert file path into URL. this is what is looks like: file://server/share/path/filename Then paste this into the URL field in SPO.

This worked and files are opening from the SPO page.

| improve this answer | |
0

I have also tried in many ways. Finally i found the solution, by adding the SharePoint online site to trusted sites list in IE(I am using IE11). This solved my issue. It will not work in chrome.

The same has to be done for on-premise environment as well.

| improve this answer | |
0

One update to the answers here: server number (000.00.000.000) is in place of the actual network drive name (S:).

It sounds like a "so what?" type of correction but if the link to your network drive and/or folder includes PDFS... they won't open unless the Acrobat program you use allows PDF files to access all web sites.

Confirming the status of this option is through Edit>>>Preferences>>>Trust Manager>>>Change Settings>>>PDF files may connect to web sites to share or get information (at top of "Manage Internet Access" or Change Settings window).

If you're updating SharePoint at your workplace (corporate, government, etc.) it most likely is disable (greyed out) with the "Block PDF files' access to all web sites" option selected. If so, the only option for you is to use the actual network drive name instead of the server number and I don't believe that will work.

Again, this is specific to PDF documents so keep that in mind.

| improve this answer | |
-1

Though adding the site in trusted sites list is a right solution, you can't implement it for the large number of people.

| improve this answer | |
-1

This is Venkatesh, we can first edit the SP page-->select the ribbon page button --> in that we can select "Link" option then we can give the your desktop or your url like "\1.1.1.1" like that it works on IE only and not work on ""chrome " and Firefox

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.