0

I have put a hyperlink to an Excel file in our SharePoint (Online) to my company's intranet. How can I manage the file opens by default in Excel, not in Excel Online? Excel Online does not support certain features of the file.

I tried adding ms-excel: in front of the link and removing the part after the question mark but always get an error message

"This action could not be performed because Office does not recognize the command it was given".

Any recommendations?

0

If the file is in a SharePoint library you can configure the library no default open in application and not online.

  • Hi Morten, sounds like a solution to my problem - can you tell me how I can do it? I am working in SharePoint Online and am the owner of a site. Do I need a SharePoint administrator to do it or can I do it myself? If so, where in the menu can I find it? Thanks for your help. – Kathrin May 19 '16 at 9:16
  • As long as you have permission to the library settings you can do it. It's should be under "Advanced settings" in the library. – Morten K May 19 '16 at 9:25
  • Hi Morten, I think I found the menu ("Default open behavior for browser-enabled documents") and changed it from "Use server default (open in the browser" to "Open in the client application". Unfortunately it still opens in Excel Online. Is there any other setting I need to change? Thanks! – Kathrin May 20 '16 at 1:54
  • It is an .xlsm file. – Kathrin May 20 '16 at 2:02
  • Sorry then I don't know why. – Morten K May 24 '16 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.