My scenario is:

  • A 2010 environment that function as it should, with custom webparts.
  • A 2013 environment where I did the migration from 2010. I extracted the farm-solutons from the 2010 environment and delpyed them in my 2013 environment.

Now, most of the things function, and most of the custom web parts fuction, but besides the webpart/webparts which are talking with a Webservice. The error is something like this:

"There was no endpoint listening at http: //blablabla/blablabla.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details."

So, what I did was go the old web.config file trough and copy/paste the lines where the endpoint is defined, and paste it in my new 2013 config file. That did not solve my problem. When I enter/browse the endpoint url, it works from the old servers, and from my client but does not work from my new 2013 servers.

What should be my next steps in this? Did I the right extract/deployment or is it something else?

So in short, webservice works in old environment, but after migration the webparts using the webservice throw the above error.

  • which end point it is asking? Please make sure the STS services is running?
    – Waqas Sarwar MVP
    Jun 10, 2014 at 17:41
  • The STS service is running as I can see under the Manage Services in CA. It is the "xisoap" webservice, something SAP related. Should I change my web-config file, or should it be populated automatically with the endpoint entry when deploying the solution to the farm ? But, I will take a look at my STS again, and see if i missed something.
    – emo
    Jun 10, 2014 at 18:00
  • I think you need to explain the thing, The error above mentioned very much generic, what Services you are using, as you mentioned SAP, did you implement the SAP connector or else? may be some configuration required for SAP.
    – Waqas Sarwar MVP
    Jun 10, 2014 at 18:15
  • I didnt do anything, then just extracted solutions from old environment, and then deployed them to the new 2013, so all my custom made webparts become available for the 2013 environment. I assumed if it worked in 2010, then just deplying solution to 2013 will also work. But I obviously need some more configuration. I tried to replicate the 2010 environment as closely as possible.
    – emo
    Jun 10, 2014 at 18:51

1 Answer 1


Okay I think that I did solve this issue. The DNS entry for the WebService was not set-up for the new environment. So when this was done, the WebService end-point did answer.

If no DNS entry, then one could use the direct IP as entry to the WebService. A lot of time spent on this, and in the end it could be something easy like this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.