1

I need to clone our production farm as test environment. Our system team cloned Frontend,Application and Database servers (virtual machines) and added domain with new server names. After that I did all things at the following link but configuration wizard still pointed to old (production) database server. What did I miss here??

http://www.meritsolutions.com/microsoft-sharepoint/cloning-sharepoint-2013-environment/

P.S. : Also link at this question is not working now Reconfiguring SharePoint 2010 Portal

Thanks in advance.

  • Open C:\Windows\System32\cliconfg.exe on your Web Frontends and your App Servers. In the Alias Tab check if the entry points to the new Database Server. – SunP Jan 11 '17 at 14:31
0

You can do this from Central Admin. If the wrong content database is being referenced, detach it and attach the content database residing on the new SQL server.

Here's the steps you need to do each.

Attach or detach content databases in SharePoint 2013

0

Cloning a SharePoint farm is hard. It might even be unsupported through Microsoft.

For another time (your next SharePoint farm) I would suggest the following:

  • Install SharePoint farms always automated with https://autospinstaller.com/
  • The config XML for AutoSPInstaller is easely changed to match new server names
  • This way you can reuse the XML file for new installations - installations will be exactly the same
  • From here on you'll have the same farm setup and your web applications created
  • Now it's easy to attach your production content DBs to your new environment
  • Attaching service application DBs is working for most of the service applications as well - and the others (e.g. search DBs) are not needed to copy

And as a bonus: It's especially useful to make an automated installation in desaster recovery scenarios.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.