4

enter image description here

I am using SP2013 Designer to export a page from site collection A and then import to site collection B. The page contain custom layout and two webparts (search result and refinement panel).

Before import, I use notepad to amend the layout path to site collection B's layout. In the file I can see some code related to those two webparts (e.g.

<%@ Register TagPrefix="WpNs1" Namespace="Microsoft.Office.Server.Search.WebControls" Assembly="Microsoft.Office.Server.Search, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"%>
<%@ Register TagPrefix="WpNs0" Namespace="Microsoft.SharePoint.WebPartPages" Assembly="Microsoft.SharePoint, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
<%@ Page Inherits="Microsoft.SharePoint.Publishing.TemplateRedirectionPage,Microsoft.SharePoint.Publishing,Version=14.0.0.0,Culture=neutral,PublicKeyToken=71e9bce111e9429c" %> <%@ Reference VirtualPath="~TemplatePageUrl" %> <%@ Reference VirtualPath="~masterurl/custom.master" %><%@ Register Tagprefix="SharePoint" Namespace="Microsoft.SharePoint.WebControls" Assembly="Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
<html xmlns:mso="urn:schemas-microsoft-com:office:office" xmlns:msdt="uuid:C2F41010-65B3-11d1-A29F-00AA00C14882"><head>
<meta name="WebPartPageExpansion" content="full" />

..........

<title>search result</title></head><WpNs0:WebPartZone runat="server" ID="__WebPartPageLibraryZone__"><ZoneTemplate><spsswc:ResultScriptWebPart runat="server" DataProviderJSON=

)

However, after import the page, the page is able to load up without error. But all the webparts are missed. What can be the problem?

  • Could you please provide some additional information of the imported file, in particular to include register directives? – Vadim Gremyachev Jun 10 '14 at 9:14
  • I added the first few lines of imported file. Thanks! – Mark L Jun 10 '14 at 9:32
  • 2
    Aha, looks like SPD incorrectly generates the namespaces in the exported file. Please try to replace spsswc:ResultScriptWebPart with WpNs1:ResultScriptWebPart, since the namespace spsswc is not registered. – Vadim Gremyachev Jun 10 '14 at 9:42
  • I have even tried import the page back to the original site collection (using another page file name). The webparts also lost! – Mark L Jun 10 '14 at 9:43
  • 1
    Indeed it is, since spsswc namespace does not exists, please replace it with WpNs1 and import the file again – Vadim Gremyachev Jun 10 '14 at 9:51
1

I was trying to move a publishing page with Content Search web part from one site collection to another.This is what worked for me:

  1. Export page from Source site collection using designer.
  2. Replace the tag spsswc with WpNs1 .
  3. Change the publishing page layout url value of property mso:PublishingPageLayout.
  4. I uploaded the page to target site collection from browser instead of Import using designer.

I was able to see the webpart in my new sitecollection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.