I've setup Search on a SharePoint 2010 Farm. It has crawled the site perfectly and there are thousands of items in the index. However, only the admin user can search. I've been over the settings, and I don't get why normal users can't find content they already have access too. It can't be security trimmed - or can it?

5 Answers 5


We solved this by adding the service account to the "Windows Authorization Access Group". We restarted the search services and IIS and did a new full crawl. When the crawl was finished normal users finally got search results. It appears the service account for search didn't have enough access to read our end users access.

  • Makes sense. Good catch! Mar 21, 2011 at 0:50
  • How to add the service account to windows authorization access group? can you pls tell, where its located? is it in the same server where sharepoint 2010 is installed? am also facing the same issue, where the original poster , faced!
    – samolpp2
    Nov 2, 2017 at 9:33

search results are security trimmed for each and every user. Make sure users have access to files and do a full crawl again.

Let us know how things develop.

  • So even if the normal user can navigate through the site collection content, and the files in the document libraries, the same user can't search this content? That doesn't make any sense.
    – user2657
    Mar 18, 2011 at 7:28
  • 1
    I am not sure if I got you right. Maybe you can help me out with some more details. (1) You say "normal users can't find content" -what does that mean? Do they get an error message or just 0 results on the search result page? (2) If we talk about "normal users" -do you have a seperate account you are testing with? Did you try to make the test user a site collection admin to verify its a permission issue? Did you try to open the files you try to find in search, from the document library?
    – AlexPoint
    Mar 18, 2011 at 9:35

If your users have access to a document and can read it / view properties, and the admin can see the documents in the search results, but the users can't, then there's definitely something strange going on.

Some things to try

  • Verbose logging of search. Does the ULS log show up anything when users try to search
  • Write a console app that fires off a search and execute it as a "normal" user and then as an "admin" do you get any errors that the UI might be hiding from you?

Really, you just want some sort of error message that you can post here for us to help you further.

  • I didn't know I could verbose logging searches. I guess I will have to Google that.
    – user2657
    Mar 22, 2011 at 7:34
  • Central Admin > Monitoring > Configure Diagnostic Logging; Tick SharePoint Server Search and set event level to Verbose. Obviously don't leave it on long-term. Mar 22, 2011 at 17:47

I left something out above ... have a look at this as well:


Have you got a one-way trust?

  • Thanks for the suggestion. However, this is all running in one domain. This problem was solved by adding the service account in the right access group. The selected answer for this question above. :)
    – user2657
    Mar 22, 2011 at 7:33

let me guess. You have your machines in one domain, and your users in another.

Try this : http://technet.microsoft.com/en-us/library/cc263460%28office.12%29.aspx


Works for me!

  • The linked articles do not address the problem in the original question about not seeing search results.
    – lwbecker2
    Aug 8, 2012 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.