2

We've checked our permissions, and our users have read access to the subsites in question. The site collection admins can view all pages just fine. Normal users can access the content by accessing the site through http://[server]/sites/Test/Subsite/_layouts/sitemanager.aspx. The problem only appears on subsites. People just get "Access Denied" error messages unless they have SCA access.

We think it might be related to the default.master, but it seems ok. The default.master permissions are correct, it's not in draft mode, and we've opened it matches working default.master pages on other sites.

Any ideas?

4

Double check that the pages have been approved. Also make sure that your page layout is checked in and approved.

  • This one solved my problem of home page not being accessible despite site contents were accessible. Thanks Gary :) – Merin Nakarmi Jan 17 '14 at 20:16
2

It turns out that permission to the site collection master page gallery had been removed. So even though the users had permissions to the master page gallery on the subsite, they were getting access denied errors on the subsite. We're not sure how the permissions on the site collection master page gallery were removed.

0

Please log on the site using a site collection administrator account, then go to Site Settings->Site Collection features, find "Limited-access user permission lockdown mode" feature, make sure it is deactivated. If it is activated, please deactivate it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.