3

I have tried 2 scenarios to update the term store data (on a wiki page content type)

  1. I update a term and hit up and the changes are not reflected on a content type (wiki page) where I am using that meta data item. After making the term item update (changing text) and navigating back to the wiki page I inspect the properties and the value is not showing the updated value.

  2. The other scenario...I have also tried to merge term store items. In view mode the page property shows the old label value. When I go into edit mode it shows the correct value which is good however this also would require me to navigate to every page go into edit mode and hit update/save on the page (in order to get the correct property value).

How can I get the label value of the meta data to update (when making changes to the term store).

I have found this article and ensured that the Taxonomy Update Scheduler is executing but the term values are not getting updated.
http://www.paulgrimley.com/2011/02/managed-metadata-changes-not-applied-to.html

NOT sure where to look now. Any ideas would be appreciated.

thx

  • Did you ever get this resolved? I'm having the same problem on a site. Kind regards, Jurgen – user7931 Apr 19 '12 at 12:51
  • David DId you had a solution for this? – user11091 Oct 3 '12 at 17:47
  • We are having the same issue with SharePoint 2013 (March CU). I read somewhere about a hidden field that needs to be updated. prashobjp.wordpress.com/2013/09/30/… But I wasn't able to get this working in my environment. – user29643 Jun 13 '14 at 11:46
1

I have the same problem and have been researching this evening. Going to follow this guy's advice for a workaround until a fix is released for this issue:

http://blogs.msdn.com/b/joerg_sinemus/archive/2011/03/03/terms-and-how-to-update-taxonomyhiddenlist-when-the-timer-job-was-not-able-to-update.aspx

  • I am finding that after running this ps script, I still need to perform and edit/save operation on each item to be complete. Submitted to Microsoft and waiting for solution. – David Feb 8 '12 at 16:23
  • Thanks David. I'm about to do the same. Do post when you get a solution. – zazie Feb 8 '12 at 23:14
  • Apparently SharePoint 2010 sp1 resolves the issue. We currently have sp1 and our immediate problem is not resolved, however while working with Microsoft we found an exception being thrown by the taxonomy service. At this point, we do not know the source of the issue. However if you have updated to sp1 and still have a problem turn on logging and look for exception. I will try to remember to update this post when we get things resolved. – David Feb 23 '12 at 2:01
1

This worked for me https://sharepoint-relieved.blogspot.com/2014/09/taxonomy-update-scheduler-not-working.html

First run a full manual sync, then reset up the database triggers.

$url = Read-Host "Enter Url of site collection" 

$site=Get-SPSite $url
[Microsoft.SharePoint.Taxonomy.TaxonomySession]::SyncHiddenList($site) 

$tax = Get-SPTaxonomySession -Site $url
$ts = $tax.TermStores[0]
$ts.UpdateUsedTermsOnSite($site)
$site.dispose()
  • This worked for me, Thank you. Article is very good though! – Pradip R. Oct 6 '17 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.