0

I've added an new term in the 'taxonomy term store'. The new terms show in the columns that are using managed meta data. I'm querying the Lists/TaxonomyHiddenList/AllItems.aspx list for id's, but these new terms are not showing in the list. I've ran the Taxonomy Update Scheduler Job thinking that this would update the list but it did not.

How do I update this list with the new terms that I've added?

1

Items only appear in this list once they have been used at least once on that site.

This is no problem for normal usage but is an issue if you are trying to set terms with workflow. In this case you will need to programmatically add the new terms to the TaxonomyHiddenList so they become available to the workflow.

  • do you have any resources on adding programattically – ironman Jun 10 '13 at 20:39
  • Sorry but I am no developer. I do know this is possible though as one of our guys developed a custom Nintex workflow action which applied a term set value to an item, creating it in the hidden list if needed. Does this help at all? stackoverflow.com/questions/2745769/… – Dave Paylor Jun 11 '13 at 9:10
0

This blog talks about adding items to the hidden list: http://nickhobbs.wordpress.com/tag/setfieldvalue/

This blog talks about the Taxonomy Update Scheduler job & updating existing list items: http://www.spcrew.com/blogs/Lists/Posts/Post.aspx?ID=13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.