1

How do I troubleshoot the task sync? I followed instructions and I believe the EWS API is installed OK and the trust relationship is there. Both SharePoint and Exchange are on-prem 2013 with the latest CUs.

I get:

"We weren't able to sync your tasks. This could be because your mailbox is on an Exchange server that isn't supported for syncing tasks. Please contact your admin..."

There is a correlation ID but I honestly do not know what you can do with that. I assume it is in some log file?

Autodiscover Command

Name : EXCHANGE13 AutoDiscoverServiceInternalUri : https://exchange.xyz.com/Autodiscover/Autodiscover.xml

From ULS:

04/09/2018 13:55:58.68 w3wp.exe (0x1F04) 0x06B8 SharePoint Server Search Exchange Integration ah9c2 Medium AutodiscoverLocalException: Autodiscover blocked a potentially insecure redirection to https://exchange.xyz.com/autodiscover/autodiscover.xml. To allow Autodiscover to follow the redirection, use the AutodiscoverUrl(string, AutodiscoverRedirectionUrlValidationCallback) overload. 0adf5b9e-fc44-a017-22e1-e9a3888bda7d

04/09/2018 13:55:58.68 w3wp.exe (0x1F04) 0x06B8 SharePoint Server Search Exchange Integration aiwxi Medium SearchServiceApplication::ExchangeAdapter::SharePoint CorrelationId:; Exchange Request Id:; Diagnostic Info: 0adf5b9e-fc44-a017-22e1-e9a3888bda7d

04/09/2018 13:55:58.68 w3wp.exe (0x1F04) 0x06B8 SharePoint Server Search Exchange Integration ai1pi Medium Autodiscover Diagnostics EWS Client Version: 15.00.0516.014 0adf5b9e-fc44-a017-22e1-e9a3888bda7d

Using:

Get-ClientAccessServer |fl identity,autodiscoverserviceinternaluri

The output is now:

Identity : EXCHANGE13 AutoDiscoverServiceInternalUri : https://autodiscover.xyz.com/Autodiscover/Autodiscover.xml

I have a host name of autodiscover pointed to the IP of the server. The cert is OK as it is a wildcard.

  • 2
    The correlation ID will be in the SharePoint ULS logs. However, I would suggest not using Exchange Task sync. This functionality no longer exists in SharePoint Server 2016 or SharePoint Online. – Trevor Seward Apr 7 '18 at 20:00
  • Thank you. I found a log viewer that helped tremendously. I know the sync is gone in 2016 but they boss wants this wrong. I need to get him to discuss our path forward since MS really wants you to use one of the other cloud apps for items like this, hence the removal from 2016. – djn602 Apr 9 '18 at 15:55
  • 04/09/2018 10:45:10.26 w3wp.exe (0x1F04) 0x1B00 SharePoint Server Search Exchange Integration ah9c2 Medium AutodiscoverLocalException: Autodiscover blocked a potentially insecure redirection to exchange.xyz.com/autodiscover/autodiscover.xml. To allow Autodiscover to follow the redirection, use the AutodiscoverUrl(string, AutodiscoverRedirectionUrlValidationCallback) overload. 1fd45b9e-1c36-a017-22e1-e524a3b28891 I do not think I can modify the code in the EWS API to solve this? Can I? What is the solution? – djn602 Apr 9 '18 at 15:56
  • Is your autodiscover domain the same as your other Exchange domains? Is your autodiscover URL running over HTTPS? – Trevor Seward Apr 9 '18 at 15:56
  • It is HTTPS. autodiscover is working for Outlook just fine. It points to exchange.xyz.com. Our local domain is xyz.local but I do not believe I am using that anywhere. – djn602 Apr 9 '18 at 16:23
0

1.Make sure User profile synchronization server is up and running .

2.Make sure you have Work Management service application running for your SharePoint Farm .

3.You also need have Search service Application

Follow the article to configure sync task from here .

Additional ,You need to check and verify the AD domain is added as an accepted domain in Exchange .

https://social.technet.microsoft.com/Forums/office/en-US/9fe2e7e4-1a8d-4249-979b-30574c043dbb/sharepoint-2013-exchange-2013-task-sync-error?forum=sharepointgeneral

  • I found the issue but have no idea what to do. AutodiscoverLocalException: Autodiscover blocked a potentially insecure redirection to exchange.xyz.com/autodiscover/autodiscover.xml. To allow Autodiscover to follow the redirection, use the AutodiscoverUrl(string, AutodiscoverRedirectionUrlValidationCallback) overload. – djn602 Apr 9 '18 at 14:50
0

In my case I had turned off TLS 1.0 and that was causing this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.