0

I am having a document Library in SPO. When I click on the list alerts I am getting an error:

enter image description here

Nothing is said in this message.

I am having "Designer" permissions with the right "Manage alerts" enabled, can any one help on how to fix this issue?

0

It’s the default behavior that user cannot create alert when we set read access on their own items.

As a workaround, you can create a custom workflow to use “send email” action and start workflow automatically when the item changed in SharePoint Designer.

Here is a similar post for your reference.

  • SP_Admin (or users with Full Control - could be a site adminsitrator) can also set up alerts for other users. – Tally Mar 27 '18 at 8:38
0

I would just add to Hellofiona's answer by explaining something which she alludes to. If you check in the List Settings>Advanced Settings.

Hellofiona suggests that you need to check that 'Read access' is set to Read all items and not 'Read items that were created by the user'.

Advanced Settings screen shot

  • Yes I have checked this. But I cant found this option in my Advances Setting : ibb.co/jG8i0S Where is this option ? – Hyro Mar 27 '18 at 9:16
  • I looked at your screen shot, I realise now that you are working with a Document Library (Excel, Word etc) and not with a List. The Advanced Settings menu is different. My answer and Fiona's answer are based on Lists rather than Document Libraries. Unfortunately I don't know how to help with your question. – Tally Mar 27 '18 at 11:22
  • For your information, here is a guide to setting up alerts on document libraries - this shows how it should work. – Tally Mar 27 '18 at 11:28
  • Ye, thats not my problem. – Hyro Mar 27 '18 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.