0

I am the Sharepoint Administrator, I have full control of the site collection and yet I am unable to delete a Document Library.

In the Document Library settings the 'delete document library' text does not appear. In the Content and Structure' menu the delete option is greyed out.

I have checked my permissions and I am in the OOTB Owners Group (Full Control).

I was testing Records Management in this Document Library, but it is now empty. I deleted one file from there today, I did Undeclare Record' on the file, deleted it and emptied the recycling bin (in case that was preventing the Doc Library deletion).

  • Hi can you check by open the browser with run as administrator – Sunil Sahu Oct 31 '17 at 13:35
  • Hi, thanks for the suggestion. I have tried this now, but it does not give me the option to delete. – Tally Oct 31 '17 at 13:45
2

You can force it using PowerShell CSOM:

$list = $ctx.Web.Lists.GetByTitle("Some Library")
$list.AllowDeletion = $true
$list.Update()
$list.DeleteObject()
$ctx.Load($list)
$ctx.ExecuteQuery()
  • Thanks for the suggestion Bunzab. I didn't try this in the end, as I've found another answer. But that doesn't mean your answer would not work! – Tally Nov 3 '17 at 11:49
1

Try this ,check any checkout file take the ownership and delete the document library

Go to the 'Document Library Settings' page of the respective 'Pages' library. Under the 'Permissions and Management' group, there is a link named 'Manage files which have no checked in version' (in SPS 2013).enter image description here

  • I followed your instructions and got someone else to upload a test document but keep it checked out. I then took control of the document (following your instructions) but no option to 'Delete Document Library' appeared I simply took control of the document. – Tally Oct 31 '17 at 14:35
  • @Tally try by opening your site in sharepoint designer and delete there – karthik Oct 31 '17 at 15:33
  • Thanks for the follow up suggestion Karthik. I tried deleting it via Designer and got the message 'Could not save the list changes to the server'. – Tally Oct 31 '17 at 15:51
  • delete the all columns in that library and then refresh the designer and try once – karthik Oct 31 '17 at 15:59
  • are you able to see delete this document library under the permissions and management in library settings you can delete from their also – karthik Oct 31 '17 at 16:01
0

A colleague found the solution to this - here is the blog post he used to kill off the Document Library. It is important to note that this document library had been used for Records Management.

  • All existing Records have to be undeclared.
  • Hold "Processing and Reporting” timer job can then be run manually (see link).

It's worth noting that the problem will rectify itself if you wait for the next scheduling timer job to run (this depends on how the timer job has been configured though, mine was set to run once per day, overnight).

26/01/2018: additional info to help other users troubleshooting the scheduling timer job. This post from SP Maven says the Timer Job default can be as much as 3 weeks before it runs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.