I have create a new site collection based on the records center template. In this site collection I have a records library "records" which has automatic record declaration turned on (so all files are records).

I uploaded some files to this library through the drop off library and content organizer rules and uploaded the files to folders (creation based on properties of the uploading file) inside this library.

Later I tried to delete the files in this folder and SharePoint told me that this is not possible as the file is a record. This is the expected behaviour and this is OK. But then I tried to delete the folder the file is in (one level up inside the records library) and I was able to delete the folder. So now the folder and the file(s) inside was gone. No exception or error message was shown. (Folder landed in the recycle bin and I am able to restore folder and file from there).

Is this some weird bug or is this the intended behaviour? After all the file inside is still a record and shouldn't get deleted. Or do I have to adjust some setting?

1 Answer 1


I can confirm that it is not inteded behavior. I just tested it though my VM and was unable to delete the folder. It was built on the Records Management site template as well. I got the message "Folder cannot be deleted because it contains items which are either on hold or declared as records."

  • Weird. Which CU do you have installed? We have SharePont 2010 SP1 and I think the CU February 2012. But let me recheck.
    – Shihan
    Apr 18, 2012 at 9:49
  • It seems we have installed CU December 2011 (14.0.6114.5000).
    – Shihan
    Apr 19, 2012 at 13:17
  • I am only up to Service Pack 1, no CU's. My vm is Microsofts Information Worker demo.
    – Cory
    Apr 19, 2012 at 16:18
  • Well I mark your answer as accepted because it is correct. Also the problem does no longer exist. I noticed that you can set what the "Record" flag means. You can set it to "block edit/delete", "block delete" or no change of behaviour at all. I'm pretty sure it was on "block edit/delete" all the time but maybe it was simply a mistake.
    – Shihan
    Jul 12, 2012 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.