0

This is my first topic so I apologize if something is not in order and I apologize for my bad english.

I have a problem with a particular SP13 list.

I created an XSL that uses JQUERY and BOOTSTRAP to format some lists.

XSL is working normally and formatting as there was project in a list.

While in another list it only works when the user is logged in, when the user is not logged in it misconfigures the entire list.

The strange thing is that in the first list it works normally even with the logged off user.

I have already compared the lists and I can not find the BUG.

Any idea what that might be?

  • is the two list in the same site and use the same customization and the same css / jquery file ? – Mohamed El-Qassas MVP Nov 28 '16 at 13:32
  • In fact my structure would be divided by list. I end up replicating the files by list type because I change some formatting classes in each type. Change of color, size, etc. But I do not change anything in JQUERY that has the function to make the accordion work. Example: List 1 --CSS --XSL --JS List 2 --CSS --XSL --JS – user2642043 Nov 28 '16 at 13:43
  • try to publish the modified css file related to list 2 as a major version – Mohamed El-Qassas MVP Nov 28 '16 at 13:50
0

I think you have modified some files related to the second list that not published as a Major version

So Try to save and check in your files then publish it as a major version as shown below

Enter image description here

Now the visitors' users should see the customization of list 2

  • Thanks for the help bro I had really forgotten something. But now I have another problem. The native Modal is not opening. Uncaught TypeError: Can not read property 'hiddenButtonValueBeforeDialog' of undefined (...) I do not know what it can be. – user2642043 Nov 28 '16 at 17:25
  • <script type="text/javascript"> function dialogfunction(pageUrl) { var options = { url: pageUrl, width: 800, height: 600 }; SP.SOD.execute('sp.ui.dialog.js', 'SP.UI.ModalDialog.showModalDialog', options); } </script> <a class="produto-item" href='javascript:dialogfunction("/_layouts/15/listform.aspx?PageType=4&amp;ListId=%7BDDBCA2F6%2D0FD1%2D4472%2D9CC8%2D1BC8BFDF3C41%7D&amp;ID={@ID}")' onmouseover="javascript:this.style.cursor='pointer';"> </a> – user2642043 Nov 28 '16 at 17:29
  • you are welcome :) are you forget the publish of major version or something else ?! for the another issue should you elaborate more to can help you faster – Mohamed El-Qassas MVP Nov 28 '16 at 17:30
  • where's hiddenButtonValueBeforeDialog in your posted code ? i can't find it – Mohamed El-Qassas MVP Nov 28 '16 at 17:57
  • So this time I'm posting the biggest version. On the other case it happens that I need to open the list item in the form of a modal. And for this I am using the Sharepoint native. But it happens that you are giving the error Uncaught TypeError: Can not read property 'hiddenButtonValueBeforeDialog' of undefined (...) or similar by changing function only. link – user2642043 Nov 28 '16 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.