I have inserted a web part on a Sharepoint (2010) page that displays contents from another web page. This displays fine in Chrome, but neither works in Internet Explorer nor Firefox. The web page by itself (navigated in a different tab/window) works fine, but not when it is displayed as a web part.

Internet Explorer - error message:

Content was blocked because it was not signed by a valid security certificate. For more information, see “About Certificate Errors” in Internet Explorer Help.

Firefox - error message:

Your connection is not secure. The owner of has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

Is this a Sharepoint problem (since the web pages don't work in the Sharepoint web part) or other problem? And is there a solution for this?

2 Answers 2


This is not sharepoint problem rather it is issue with I.E. Enhanced security which is causing the issue.

You can disable the certificate check from IE to disable it or use the below link for other options


  • Thanks for the suggestion. I unchecked "Check for server certificate revocation" in Internet Options and restarted, as described, but the web part still blocks the content. I'd like to reiterate that the website i'm trying to display in the web part works in a separate IE or Firefox tab, when browsed to.
    – Sandy
    Apr 28, 2016 at 15:35

Apparently the Sharepoint was set up as an HTTP site and the content I was trying to get displayed was from an HTTPS web server, so the real issue here was mixed HTTP and HTTPS content. The browsers didn't like this, so they didn't display content in the web part. I don't know why Chrome didn't block the content. To solve this, I gave the web part an HTTP URL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.