11

I'm trying to run the following PS command on a SharePoint 2010 Foundation Farm:

Update-SPSolution -Identity testwebpart.wsp -LiteralPath C:\ChrisProjects\TestWebPart\TestWebPart\TestWebPart\bin\Debug\TestWebPart.wsp -GACDeployment

But I'm getting the following error:

Update-SPSolution : Cannot uninstall the LanguagePack 0 because it is not deployed. At line:1 char:18 + Update-SPSolution <<<< -Identity testwebpart.wsp -LiteralPath C:\ChrisProjects\TestWebPart\TestWebPart\TestWebPart\b in\Debug\TestWebPart.wsp -GACDeployment + CategoryInfo : InvalidData: (Microsoft.Share...tUpdateSolution:SPCmdletUpdateSolution) [Update-SPSoluti on], SPCmdletException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletUpdateSolution

I'm looking everywhere for a resolution, but can't find one... I tried restarting the SharePoint 2010 Admin/Timer services, nothing. I tried removing the wsp, but couldn't do it. I tried deploying through CA, that errored out saying the feature had already been installed. Not sure what to do at this point.

I can remove the solution through CA. I then go back to VS, rebuild the wsp and run the following command to get it back on the farm:

stsadm -o addsolution -filename C:\ChrisProjects\TestWebPart\TestWebPart\TestWebPart\bin\Debug\TestWebPart.wsp

I go back to Central Admin, and there it sits. Then, when I go in to Deploy it, I get this message:

A feature with ID ab488346-be08-4a61-aabf-abad966ba10c has already been installed in this farm. Use the force attribute to explicitly re-install the feature.

I am SO lost... I really hate SharePoint.

UPDATE

I'm not really sure why or how, but all of a sudden it's working. I just tried to remove and then readd the package, following the exact same steps above, which I had already done 5 times, and it suddenly worked.

Albert Einstein once said, "Insanity is doing the same task repetitively expecting a different result". Obviously, Mr. Einstein has never worked with SharePoint.

  • 2
    I like your quot.. haha – Mark L Oct 20 '16 at 2:56
1

try the following steps

  1. Checked the solution store(Central Administration–>System Settings–> Manage farm solutions) and saw that the solution I was updating was not deployed and thrown error. The error it gave was not able to do GAC diployment of the dll. So i went to GAC and uninstall the WSPs related dlls and deployed the wsps again from central admin.

  2. From services.msc I stopped and restarted the SharePoint 2010 Timer service and the SharePoint 2010 Administration service.

  3. Then i ran the power shell command again. this time the WSP got updated.

https://blogs.msdn.microsoft.com/kunal_mukherjee/2012/11/12/error-cannot-uninstall-language-pack-0-because-it-is-not-deployed-when-attempting-to-uninstall-spsolution-on-sharepoint-2010-foundation/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.