0

I have a solution containing a Visual WebPart and an Application(_Layouts) page. I have used VS 2013 for developing this solution and its for our 2013 farm. The farm has one Application Server and 2 WFE Servers along with other servers.

I am using following commands on one of my WFE,

Add-SPSolution -LiteralPath "D:\Solutions\bin\Release\MySolution.wsp"

Install-SPSolution -Identity "MySolution.wsp" –WebApplication "https://www.software.web.com/" –GACDeployment

The commands ran without error.

But after running the command, i cann't see the WebPart and even the Layouts folder and Page were not present on the server.

CA shows that the solution is deployed only to the APP server.

Any help is greatly appreciated.

  • Check if the SharePoint Timer Service is running on all the App & Web Servers. If they already started, restart the timer service on all servers and deploy your solution again. – Ram Feb 11 '15 at 2:09
1

Thanks everybody for investing time in this.

It turned out to be the Microsoft SharePoint Foundation Web Application service. On one of the WFEs this service was stopped. When i started it and tried again. The solution got deployed to WFE01 and APP01. Previously it was getting deployed only to APP01.

Now, still the solution is not deployed on WFE02. And, the dilemma i am in is that this server don't even displays Microsoft SharePoint Foundation Web Application service in the list of services.

Does only one WFE in the farm need to be running this service ?

0

SharePoint Farm solutions can be deployed either Globally or to specific Web Applications.

The web part and other artifacts will get deployed through features. Hence if you want to use your web part then activate the feature it's associated with.

  • OP is talking about missing files from physical path. Application page and perhaps if it is visual webpart then .ascx should be present in control templates folder. – Nadeem Yousuf Feb 11 '15 at 3:08
  • @Amal Don't you think it should be automatically done when i run Install-SPSolution. Moreover, the first issue is the solution was not deployed on any of the WFE. So, the feature would not be available for activation. – Amit Tyagi Feb 11 '15 at 17:58
0

Check if the IIS showing all the Web Application on this server if it's not showing sites then service is not running you need to run this service using power shell command or from Running services on this server from the Central Admin make sure you select the correct server name from the available drop-down of servers names

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.