4

I had a team site owner contact me wondering why they can't sync to a new file library that they've created. (See image.)

enter image description here

So I went and did some exploring. They added a bunch of content types, and changed the default content type to a visio file and changed the default template to a visio. I got the document content type to be default and added a word document to be the template. Didn't make any difference.

They have content approval turned on, I thought that might cause it. It doesn't.

They have check out turned on to edit, that didn't matter either.

I thought it might be an Asset Library, it isn't.

You can still connect to Windows File Explorer up on the Library ribbon. When I copy the library and create a template of it, it still retains the same behaviour.

When I create a new document library in that site, it works fine.

I must be missing something, but I'm running out of ideas. Any assistance would be appreciated.

2
  • 2
    Library settings -> Advanced Settings -> Offline Client Availability. If set to No, you cannot sync it. What is that setting? – Eric Alexander Jan 25 '16 at 18:17
  • Thanks Eric, but it's set to yes. – Steve Morley Jan 25 '16 at 19:23
0

Go to Site Settings --> Search and offline availability --> Allow items from this site to be downloaded to offline clients, set it to 'Yes'. After this settings, it should allow to sync libraries from that site.

Reference post - https://techcommunity.microsoft.com/t5/SharePoint/Issue-with-Sync-button-missing-in-Modern-Document-Library/td-p/49141

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.