0

I have a three 2010 event handlers installed on-premises on 2013 foundation that are all part of the same solution (added, updating, updated), none of which are triggering when they are attached to the list (confirmed by SP Manager). I've tried writing to a list at the start of the code to show that it's running but failed. Additionally, I created a new 2010 solution that successfully writes to a list. The solution has been retracted and reactivated but still no luck. What could be the possible confliction(s) for these not running?

  • have you checked the uls logs? – Gwny Jul 13 '15 at 12:21
  • ive checked the sharepoint log viewer logs but there was nothing I could find. would this be different to the 'uls' logs – matt Jul 13 '15 at 16:30
  • did you upgrade your solution for 2013? – Gwny Jul 14 '15 at 6:56
  • no its 2010. just deployed to another site and its working with sharepoint online – matt Jul 15 '15 at 14:08
0

Make sure that the event receivers exist in one of your project features. also make sure that this feature is activated on your website. Finally try to change the scope of the feature (I don't think it will work if the scope is "Web", try to make it "Site") P.S. You don't have to add code for testing writing to a list to show that it's running. You can just attach debugger to your IIS Worker Process (w3wp) and insert break point at the start of your code.

  • the feature is activated on site and subsite level, still no joy – matt Jul 13 '15 at 16:31
  • what about the other points? – John Magdy Jul 14 '15 at 14:44
  • is your receiver in one of your features? you could rename your *.wsp to *.cab and check if the dll and definition is in there. – Gwny Jul 16 '15 at 6:19
  • yes theyre all part of the same feature – matt Jul 16 '15 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.