1

I'm inserting items into a List via REST (authenticated with the SP Administration login).

The list has an ItemAdded, correctly attached (I checked with SP Manager)

The event starts firing only after an item has been added from the web interface; after that, it will always be fired regardless of how the item has been added - via REST or from the web interface. It's not a duplicated of my other question, which I already addressed in that thread: here the AAM are correctly set.

The Server is a Sharepoint Foundation 2013.

Sharepoint Timer Service and Microsoft SharePoint Foundation Workflow Timer Service are both started and automatic.

Where should I look?

UPDATE

After manually updating the item (from the web UI) the event receiver starts firing. Seems that the intervention from the web interface activates something that the REST doesn't.

  • possible duplicate of ItemAdded not firing with REST – Naveen May 4 '15 at 14:04
  • @Naveen: no, it's not a duplicate. That issue has been solved, in the same environment: here the behaviour is completely different. – En-j May 4 '15 at 18:34
0

After many attempts, I solved as follows:

  • I deploy it as a farm solution
  • I run the code with SPSecurity.RunWithElevatedPrivileges

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.