3
  1. I created a new Web Application (Claim based) and Anonymous is not checked (Create claims-based web applications in SharePoint 2013)
  2. Then I created a Site Collection under the root of the new Web Application
  3. I get Access Denied with the most powerful service accounts and all other accounts.

I saw a YouTube video where anonymous is not checked and he was able to get to the site without Access Denied. (Enable Windows Authentication is checked, Integrated Windows Authentication is checked with NTLM)

However, I created another site collection but the url is /sites/test and this site does not throw access denied after prompting for user credentials for the first time. The root site collection is throwing access denied no matter who is the user.

  • are you trying to access the site from server itself or from the client pc? try from server? also one thing i want to understand....only root site collection getting access denied and all others working fine? – Waqas Sarwar MVP May 12 '15 at 13:53
  • Waqas: I am trying to access it from WFE. I tried Amal's suggestion back and forth few times but it did not help. others sites are fine. – Miley Jordan May 12 '15 at 14:00
  • what template is being used for the root site collection – Waqas Sarwar MVP May 12 '15 at 14:01
  • sts#1 is the template i used with powershell. $template = Get-SPWebTemplate "STS#1" #Blank Site $url = "intranet.contoso.it" New-SPSite -Url $url -Name "FM O&G Home" -OwnerAlias "admin-mjordan" -Template $template -ContentDatabase Content_Intranet_DB | Set-SPSite -QuotaTemplate "10GB" – Miley Jordan May 12 '15 at 14:15
  • So you are using a blank template, right? Now try to delete the Root site collection, recreate with different template like team site STS#0 – Waqas Sarwar MVP May 12 '15 at 14:19
1

I had to use powershell to set user policy. Looks like when I used Central Admin to set user policy it did not do the trick. The powershell superuser full and read worked. Access Denied from Migrated SP2010 -> 2013 Web App

| improve this answer | |
0

It seems your Web Application Authentication settings got corrupted somehow. You can try to clean this up by simply Enabling and Disabling Anonymous Access.

You can do this by

  1. Open Central Admin Site
  2. Open Application Management & Select Manage Web Applications
  3. Select web application in question and open Authentication Providers
  4. Choose default authentication provider zone
  5. Check Enable Anonymous Access and Save

Now do the same steps as above and in step#5 - Uncheck Enable Anonymous Access

| improve this answer | |
  • Hi Amal, I tried enable anonymous and it did not help. so i disabled anonymous and it did not help either. – Miley Jordan May 12 '15 at 14:00
  • Hi Amal: yes, thats the step I took and tried it multiple times. Should I need a IIsREset after this? – Miley Jordan May 12 '15 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.