4

I've migrated a web application's content database from SP2010 to SP2013. After the migration was complete, I am completely locked out of the web application. Navigating to the root site collection prompts me for credentials which are refused every time. The user I'm trying to log in as is a farm administrator as well as site collection administrator.

I've tried using PowerShell to get myself access (this is also part of the migration procedure):

$account = "yourDomain\yourUser"
$account = (New-SPClaimsPrincipal -identity $account -identitytype 1).ToEncodedString()
$wa = get-SPWebApplication $WebAppName
$zp = $wa.ZonePolicies("Default")
$p = $zp.Add($account,"PSPolicy")
$fc=$wa.PolicyRoles.GetSpecialRole("FullControl")
$p.PolicyRoleBindings.Add($fc)
$wa.Update() 

$wa.MigrateUsers($true)
$wa.ProvisionGlobally()

This hasn't worked. I've also checked the site collection admin in Application Mangement -> Site Collections -> Change site collection administrators

That needed to be changed when it was first switched over as the previous environment was on a different domain, but the user now listed as a site collection admin cannot get to the root site collection.

I've also tried enabling anonymous access in the process outlined here and still can't get in.

This is just a personal testing environment so no worries about trying anything that breaks, I can always revert the VM.

How can I regain access to this web application?

2

did you set you Object cache user(Super User and Super reader properly? If not please set it. Add them in policy for web app

Step 1 Super User should have Full control on web app

Super Reader account should have Full read on web app

Step 2 Then run the below powershell to fix it.( make sure you use the claim identifier when running the below commands, other wise you will get access denied again. Cliam:domain\username.

$wa = Get-SPWebApplication -Identity "<WebApplication>"
$wa.Properties["portalsuperuseraccount"] = "<SuperUser>"
$wa.Properties["portalsuperreaderaccount"] = "<SuperReader>"
$wa.Update()

Step 3: Reset IIS on all servers

1
  • I have tried this, I apologize for not mentioning it. This also did not work. – tnw Jan 10 '14 at 15:33
0

might be silly but have you added the user account to the webapplication in central admin?

central admin -> application managment -> manage web applications -> On the WEB APPLICATIONS tab of the ribbon, click the web application for which you want to manage permissions.

now click on user policy and add the user account to this by clicking new and give full control!

This should give you full access to the whole web application!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.