3

I've made a simple html page layout, uploaded to my SharePoint online along with associated js/css and folder structures for the site. I've ensured that these files have been published and the site pulls them through when viewed.

So far, so good.

However, when i need to edit the files they are not showing in SharePoint designer? I can see them when viewing to my network mapping in Explorer but designer refuses to acknowledge them. What's really strange is if I use the 'Import Files' (lets say on a css file) that I know is up there. It identifies the file and asks to be overwritten.

As per my screenshot of SP designer and Explorer you can see the files are there as explained above.

Anyone know why I get this anomaly in SP designer?? Sure I can edit them if I use my mapping but isn't this what SP designer is for?!

Scott

scr1

4

Follow the below steps.

Should Navigate All Files --> _catalogs --> masterpages

1

I had the same issue with SharePoint Designer when I import files and I cant see the catalogs folder. I had to enable "Show catalog lists and system objects" option.

enter image description here

This still does not show the imported files when I goto "Master Pages" link directly but if I goto "All Files", I can see the "_catalog" folder and if I navigate to "masterpage" with in the _catalog folder, I can see all the files.

Still looking at various options and will update my answer if I find something.

  • Thanks to Vidhyardhi Gorrepati for one possible solution, this solved my problem. – user1284209 Feb 20 '17 at 8:03
0

make sure the user that you use to open the site has access to the master pages library.

also sometimes SPD can't load files, you need to close it and open again.

  • Yeah i've stuck my user in the correct groups and set out all required permissions. SPD just being super weird. I can see the files like seattle/oslo html pages. – Scott White Mar 19 '15 at 15:11
0

Check setting in Central Admin.

Go to Central Admin-> General Application Settings->SharePoint Designer(Configured SharePoint Designer Settings)->Select Enable Customizing Master Pages and Layouts Pages.

Hope this will resolve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.