6

I have an list with a few hundred rows, two of which are:

  1. Title: someuniquestring1; Category: blue

  2. Title: someuniquestring2; Category: blue

These two records are the only records with a category of blue. When I search for "blue", only the first list item is returned. Searching on the unique title for the second item does work. (the real list has quite a few more columns. searching on any of them returns the first record, but not the second)

This behavior occurs on a search center site. If I search using the "find an item" search box on the AllItems page, then both records are returned when I search for "blue".

All items inherit permissions. The list does not use content approval or versioning.

Any thoughts?

11

Is this 2013? Not sure about 2010 but in 2013 SharePoint tries to helpfully trim out search results it considers duplicates, and in my experience it's not always accurate. You can tell SharePoint to allow duplicates from the query settings page in your Search results web part:

enter image description here

  • Note to askers: please, always indicate a SharePoint version along with your question. – Derek Gusoff Jun 2 '14 at 16:43
  • yes, sharepoint 2013, thanks. What does it mean if I don't have "remove duplicates" as an option in the web part? This is an enterprise search center, and I have access to the multiple tabs such as everything, people, conversations, etc. – Mike2500 Jun 2 '14 at 17:09
  • I do have the option to show the "view duplicates" link, and clicking it does then display both records. I hope there's a way to set it as the default as in your screen shot... – Mike2500 Jun 2 '14 at 17:11
  • You need to edit the Search Results web part. Click Site Actions (the gear thingy), edit page, "Edit Web Part" -> Change Query. If you can't locate these elements you probably don't have the permission required to use them, and you'd need to find someone who does to do this for you. – Derek Gusoff Jun 2 '14 at 17:20
  • I have full permissions. When I go to the "settings" tab of the "change query" dialog, I have only three settings: query rules, url rewriting, and loading behavior. I don't have the "remove duplicates" option. – Mike2500 Jun 2 '14 at 17:25
2

I found this which helped me solve the same problem http://thesharepointlife.com/2013/04/sharepoint-2013-search-not-display-all-results-2/comment-page-1/#comment-488

Quote:

  1. Export the Search Results Web Part from your page.

  2. Open the .webpart file in your favorite editor.

  3. Search for “Trim Duplicates”, you will find it as part of the DataProviderJSON property.

  4. Set the Trim Duplicates property to False.

  5. Upload the web part.

  6. Add the web part to your page.

Hope that helps

1

So sorry for answering this late. I don't think you are doing anything wrong. If you are using Query Builder to display your search results (and not doing all your query modifications from site settings), then simply go back into the Query Builder properties box of that specific web part, click on the "Settings" tab, and then click on "Don't remove duplicates".

In SharePoint you can write and manage queries from so many different areas.

0

I also could not see the Remove Duplicates option as shown in the screen shot, but it's there now after updating to the latest service packs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.