1

I have Microsoft Excel 2007 and am trying to open and edit a document from my Employer's SharePoint (I am not sure what version of SharePoint they are running, unfortunately). I have attempted to open the document by logging in to SharePoint on the latest versions of IE, Firefox, and Chrome, but all give me the same errors.

If I attempt to open the document directly, it tries for a moment then I get the following error message:

The workbook cannot be opened because it contains the following features that are not supported by Excel in the browser:

• Data validation Would you like to try and open this file in Excel?

If I use the drop-down on the right and click the "Open in Microsoft Excel" button, I get this error message instead:

The document could not be opened for editing. A Microsoft SharePoint Foundation compatible application could not be found to edit the document.

I have been able to access the document on other systems (which, of course, I don't have access to now), so I know the problem most likely stems from my current access point (though not the web browsers, apparently, since the errors are uniform across several), but beyond that I can't seem to drum up any actual solutions. Any suggestions?

1

This problem occurs when Internet Explorer cannot detect the appropriate Office add-on to allow it open the corresponding client application. Unable to detect that Office is installed, Internet Explorer instead helpfully opens the file in the browser.

Or not so helpfully, since the Excel web application cannot handle a large number of Excel features that are available in the client application, such as Data Validation.

So how do we fix this?

Don't Use 64-bit Internet Explorer

The most common problem (and easiest to correct) is the use of 64-bit Internet Explorer (which is included in Windows 7 64-bit). There are no Office add-ons for Internet Explorer 64-bit, so it will force all Office files to open in the browser, and will behave as if you simply don't have Office installed when you try to open in the client application.

Use the 32-bit Internet Explorer instead.

Repair or Re-install Office

Especially if multiple versions of Office applications have been installed on the same computer, the browser add-ons that allow Internet Explorer to open Office files can stop working. I noticed this problem when users would install a newer version of Access or Visio but still had older versions of the general Office suite; the mismatched Office products meant that Internet Explorer was looking for the newer version of Excel and could not find it.

This is easily remedied by either repairing Microsoft Office or by uninstalling and re-installing it.

Verify the Browser Add-Ons are Enabled

Check your Internet Explorer add-ons and make sure the "SharePoint Open Documents Class" add on is installed and enabled.

0

Set the Document Library Settings to open with Client Application.

In 2013, it is set to "Use the Server Default (Open in Browser)".

Go into the Library Settings-> Advancved Settings of the Document Library.

Under Open Documnets in Browser, change the default to "Open in Client Application".

0

Well now, isn't this interesting... I too had this issue starting just this morning and tried a multitude of posted solutions, all to no avail. Not one to give up easily (especially seeing that I am the SharePoint Admin as well), what I did was create a SharePoint link to the spreadsheet and that worked (funny seeing that I put the link right next to the actual spreadsheet). But this wasn't the end... I tried to save but it said that it was read-only, noticed that my check-out was removed, so closed the document, checked it out, and then reopened... it worked. From that point on I can check-out --> open --> edit --> save --> check-in --> and close just fine. I don't know why creating the link and using it helped with the fix, but it seems to be integral. Enjoy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.